Forum Index Search Forum Register Log in

Runs on XP to Win 10

Current

Download 7.0

Download 7.1 Beta5 upgrade



A donation makes a contribution towards the time and effort that's going in to running this site.

Steffen

Contact:
My mail address is
at the top of the paypal form :

Your donations will help to keep this site alive and well.


Update your links !! November 2016 the forum is at www.apachelounge.com/sambar

In the forum there are links to sambarserver.info,
replace "sambarserver.info" with "apachelounge.com/sambar"
SpamAssasin Mail CGI Failure

 
Post new topic   Reply to topic    Sambar Forum Index -> Coding & Script Corner
View previous topic :: View next topic  
Author Message
Fission



Joined: 15 Jun 2004
Posts: 5
Location: http://www.johnrhibbard.com

PostPosted: Wed 24 Aug '05 19:42    Post subject: SpamAssasin Mail CGI Failure Reply with quote

I'm getting the following line in my server log.

[2005-08-21 00:01:08] ERROR: Mail CGI failure. CreateProcess failed 'C:/SAMBAR60/perl/perl.exe C:\SAMBAR60\bin\mailcgi.pl'.

Any ideas?

Thanks -
Fission
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 414
Location: Netherlands

PostPosted: Wed 24 Aug '05 20:46    Post subject: Reply with quote

Seems that you have "Router CGI Script = mailcgi.pl" in mail.ini

This works only if you have SpamAssassin installed.
Did you ?


Steffen
Back to top
View user's profile Visit poster's website
Fission



Joined: 15 Jun 2004
Posts: 5
Location: http://www.johnrhibbard.com

PostPosted: Thu 25 Aug '05 14:23    Post subject: Let me Specify Reply with quote

I'm sorry let me give more details.

Yes I have SpamAssassin installed. I am running ActivePerl 5.8.7.813. I followed the guide I found in a link from this forum on how to install and configure SpamAssassin. In my mail overview, it says that SpamAssassin is "ON" and "Anti-spam CGI is mailcgi.pl" I thought is was working until I saw my log file filling up with the error in my last post. Now I assume that it is not working because I still get LOTS of spam emails. I am running Sambar Server V6.2 (pro) on W2k pro.

Thanks for the help.
- Fission
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 414
Location: Netherlands

PostPosted: Thu 25 Aug '05 14:47    Post subject: Reply with quote

Sure with that error message it is not working.
Here is it working fine.

check if the the first line in mailcgi.pl eg. #!C:\perl\bin\perl.exe

I assume you do not run SpamD, so in mailcgi.pl check that you have:

# my $mailMessage=`spamc < $tmpFile`;
# my $mailMessage=`spamassassin < $tmpFile`;
my $mailMessage=`spamassassin.bat < $tmpFile`;

To check if it is workng, check in the router.log for:

[ROUTERCGI] No spam found in message
[ROUTERCGI] Spam found in message
Back to top
View user's profile Visit poster's website
Fission



Joined: 15 Jun 2004
Posts: 5
Location: http://www.johnrhibbard.com

PostPosted: Mon 29 Aug '05 15:46    Post subject: Still not working Reply with quote

Steffen -

I changed the 1st line to #!C:\perl\bin\perl.exe. It was a unix path, but it is still not working. Is the pound sign "#" a comment? Also it seems that my path is wrong? CreateProcess failed 'C:/SAMBAR60/perl/perl.exe -' Perl.exe is in the c:\perl\bin folder. How do I change this? Here is my windows path variable: C:\Perl\bin\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;c:\php

Your help is very much appreciated.

Regards -
Fission
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 414
Location: Netherlands

PostPosted: Mon 29 Aug '05 16:23    Post subject: Reply with quote

Hi,

Check in config.ini:

Perl Executable = C:\Perl\bin\

Btw.
Did you test SpamAssassin following http://www.openhandhome.com/howtosa300.html ?


Steffen
Back to top
View user's profile Visit poster's website
pekka



Joined: 23 Apr 2007
Posts: 6
Location: Lappeenranta

PostPosted: Sat 06 Oct '07 12:20    Post subject: Re: SpamAssasin Mail CGI Failure Reply with quote

I spend lot's tomr whit spamasssin installation and problem's were:
-incorrect PATH
-user rights of executing process at XP PRO
-two perl distributions, one in compatible whit spamassassin version
-had to find compatible spamassassin version , no itrest to compile,...

Hope this gives some help!


Fission wrote:
I'm getting the following line in my server log.

[2005-08-21 00:01:08] ERROR: Mail CGI failure. CreateProcess failed 'C:/SAMBAR60/perl/perl.exe C:\SAMBAR60\bin\mailcgi.pl'.

Any ideas?

Thanks -
Fission
Back to top
View user's profile Visit poster's website

Post new topic   Reply to topic    Sambar Forum Index -> Coding & Script Corner
Page 1 of 1