logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Forum Register Log in  RSS Apache Lounge



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



Apr error Installing Mod_SSL

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
jdmfontz



Joined: 16 Jan 2009
Posts: 4

PostPosted: Fri 16 Jan '09 1:37    Post subject: Apr error Installing Mod_SSL Reply with quote

Running Apache 2.2

My apr pkg installed are:
[root@host58 opt]# rpm -qa | grep apr
apr-1.2.8-6
apr-util-1.2.7-7.el5
[root@host58 opt]#

My configure parameters are:

# /configure --prefix=/usr/local/apache --with-mpm=prefork --enable-ssl --disable-charset-lite --disable-include --disable-env --enable-setenvif --disable-status --disable-autoindex --disable-asis --disable-cgi --disable-negotiation --disable-imap --disable-actions --disable-userdir --disable-alias --disable-so --with-ssl=/usr/bin

I am getting the following (server/.libs/libmain.a(exports.o).data+0xa44): undefined reference to `apr_os_uuid_get') error on make:

/opt/httpd-2.2.11/srclib/apr/libtool --silent --mode=compile gcc -g -O2 -pthread -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/opt/httpd-2.2.11/srclib/pcre -I. -I/opt/httpd-2.2.11/os/unix -I/opt/httpd-2.2.11/server/mpm/prefork -I/opt/httpd-2.2.11/modules/http -I/opt/httpd-2.2.11/modules/filters -I/opt/httpd-2.2.11/modules/proxy -I/opt/httpd-2.2.11/include -I/opt/httpd-2.2.11/modules/generators -I/opt/httpd-2.2.11/modules/mappers -I/opt/httpd-2.2.11/modules/database -I/opt/httpd-2.2.11/srclib/apr/include -I/opt/httpd-2.2.11/srclib/apr-util/include -I/opt/httpd-2.2.11/srclib/apr-util/xml/expat/lib -I/opt/httpd-2.2.11/modules/proxy/../generators -I/usr/bin/include -I/usr/kerberos/include -I/opt/httpd-2.2.11/modules/ssl -I/opt/httpd-2.2.11/modules/dav/main -prefer-non-pic -static -c modules.c && touch modules.lo
gcc -g -O2 -pthread -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/opt/httpd-2.2.11/srclib/pcre -I. -I/opt/httpd-2.2.11/os/unix -I/opt/httpd-2.2.11/server/mpm/prefork -I/opt/httpd-2.2.11/modules/http -I/opt/httpd-2.2.11/modules/filters -I/opt/httpd-2.2.11/modules/proxy -I/opt/httpd-2.2.11/include -I/opt/httpd-2.2.11/modules/generators -I/opt/httpd-2.2.11/modules/mappers -I/opt/httpd-2.2.11/modules/database -I/opt/httpd-2.2.11/srclib/apr/include -I/opt/httpd-2.2.11/srclib/apr-util/include -I/opt/httpd-2.2.11/srclib/apr-util/xml/expat/lib -I/opt/httpd-2.2.11/modules/proxy/../generators -I/usr/bin/include -I/usr/kerberos/include -I/opt/httpd-2.2.11/modules/ssl -I/opt/httpd-2.2.11/modules/dav/main -c /opt/httpd-2.2.11/server/buildmark.c
/opt/httpd-2.2.11/srclib/apr/libtool --silent --mode=link gcc -g -O2 -pthread -L/usr/bin/lib -L/usr/kerberos/lib -o httpd modules.lo buildmark.o server/libmain.la modules/aaa/libmod_authn_file.la modules/aaa/libmod_authn_default.la modules/aaa/libmod_authz_host.la modules/aaa/libmod_authz_groupfile.la modules/aaa/libmod_authz_user.la modules/aaa/libmod_authz_default.la modules/aaa/libmod_auth_basic.la modules/filters/libmod_filter.la modules/loggers/libmod_log_config.la modules/metadata/libmod_setenvif.la modules/ssl/libmod_ssl.la modules/http/libmod_http.la modules/http/libmod_mime.la modules/mappers/libmod_dir.la server/mpm/prefork/libprefork.la os/unix/libos.la -lm /opt/httpd-2.2.11/srclib/pcre/libpcre.la /opt/httpd-2.2.11/srclib/apr-util/libaprutil-1.la /opt/httpd-2.2.11/srclib/apr-util/xml/expat/lib/libexpat.la /opt/httpd-2.2.11/srclib/apr/libapr-1.la -luuid -lrt -lcrypt -lpthread -ldl
server/.libs/libmain.a(exports.o).data+0xa44): undefined reference to `apr_os_uuid_get'
collect2: ld returned 1 exit status
make[1]: *** [httpd] Error 1
make[1]: Leaving directory `/opt/httpd-2.2.11'
make: *** [all-recursive] Error 1

Not certain what to make out of this.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 1692
Location: Sun Diego, CA, USofA

PostPosted: Fri 16 Jan '09 18:02    Post subject: Reply with quote

Hmmm ...

1. I do not think those APR versions are going to work with 2.2.11, APR went to 1.3.x at 2.2.9. The httpd-2.2.11.tar.gz file from ASF contains the proper APR/APU/API

2. I see nothing said about OpenSSL. You need it to build mod_ssl.

It's been some time since I compiled Apache on Linux but;

Since Apache source looks to be in /opt/httpd-2.2.11

Get OpenSSL 0.9.8j tarball from http://www.openssl.org/source/
Un-Tar/gzip into /opt/httpd-2.2.11/srclib/openssl

Code:
cd /opt/httpd-2.2.11/srclib/openssl
./config
make
make test


if all tests pass, cd /opt/httpd-2.2.11 and compile Apache again
Back to top
jdmfontz



Joined: 16 Jan 2009
Posts: 4

PostPosted: Fri 16 Jan '09 20:09    Post subject: Reply with quote

Thanks,

I removed the apr pkgs:

[root@host58 httpd-2.2.11]# rpm -qa | grep apr
apr-1.2.8-6
apr-util-1.2.7-7.el5
[root@host58 httpd-2.2.11]# rpm -e apr-util-1.2.7-7.el5
[root@host58 httpd-2.2.11]#
[root@host58 httpd-2.2.11]# rpm -qa | grep apr
apr-1.2.8-6
[root@host58 httpd-2.2.11]# rpm -ev apr-1.2.8-6
[root@host58 httpd-2.2.11]# rpm -qa | grep apr
[root@host58 httpd-2.2.11]#

Also here are the version of openssl I have:

[root@host58 httpd-2.2.11]# rpm -qa | grep openssl
openssl-0.9.8b-10.el5
openssl-devel-0.9.8b-10.el5
[root@host58 httpd-2.2.11]#

Re-ran the Apache ./configure and make after removing the apr pkgs and got same error on make. Puzzling.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 1692
Location: Sun Diego, CA, USofA

PostPosted: Fri 16 Jan '09 20:55    Post subject: Reply with quote

I'll give it a try on my fedora this weekend and see what happens for me.

However, upon further inspection, you're RPMing the toolkit from whatever distro you are using. To build mod_ssl ASAIK, you need the complete compiled source tree and it has to be in the openssl directory inside srclib, which I am pretty sure your RPMs are not doing.

Download and compile source as I said above.
Back to top
jdmfontz



Joined: 16 Jan 2009
Posts: 4

PostPosted: Mon 19 Jan '09 17:42    Post subject: Reply with quote

Just reinstalled RedHat Linux EL5 over the weekend on a new box still got same errors. Interesting.

Here are my versions of relevant pkgs installed in addition to OS:

[root@localhost opt]# ls -l
total 37616
-rw-r--r-- 1 root root 581086 Jan 19 15:02 e2fsprogs-devel-1.39-15.el5.i386.rpm
drwxr-xr-x 12 martin users 4096 Jan 19 15:20 httpd-2.2.11
-rw-r--r-- 1 root root 33484800 Jan 19 14:08 httpd-2.2.11.tar
-rw-r--r-- 1 root root 28148 Jan 19 14:59 keyutils-libs-devel-1.2-1.el5.i386.rpm
-rwxr-xr-x 1 root root 1946882 Jan 19 14:42 krb5-devel-1.6.1-25.el5.i386.rpm
-rw-r--r-- 1 root root 134479 Jan 19 14:54 libselinux-devel-1.33.4-5.el5.i386.rpm
-rw-r--r-- 1 root root 193180 Jan 19 14:56 libsepol-devel-1.15.2-1.el5.i386.rpm
-rw-r--r-- 1 root root 1932026 Jan 19 14:38 openssl-devel-0.9.8b-10.el5.i386.rpm
-rw-r--r-- 1 root root 102731 Jan 19 14:49 zlib-devel-1.2.3-3.i386.rpm
[root@localhost opt]#

Since the error references apr's, here are the versions out of the box.
[root@localhost httpd-2.2.11]# rpm -qa | grep apr
xorg-x11-drv-dynapro-1.1.0-2
apr-util-1.2.7-7.el5
apr-1.2.7-11

and here are the ssl versions:
[root@localhost httpd-2.2.11]# rpm -qa | grep ssl
openssl-0.9.8b-10.el5
openssl-devel-0.9.8b-10.el5

Here is my .config parameters again:

./configure --prefix=/usr/local/apache --with-mpm=prefork --enable-ssl --disable-charset-lite --disable-include --disable-env --enable-setenvif --disable-status --disable-autoindex --disable-asis --disable-cgi --disable-negotiation --disable-imap --disable-actions --disable-userdir --disable-alias --disable-so

This is pretty standard stuff.

When I do a ./configure --prefix=/usr/local/apache2, there are no errors. When I add the enable-ssl component there are same errors: ./configure --prefix=/usr/local/apache --enable-ssl

Problem with mod_ssl lib?
Back to top
jdmfontz



Joined: 16 Jan 2009
Posts: 4

PostPosted: Tue 20 Jan '09 17:52    Post subject: Reply with quote

Follow-on. I uninstalled apr and apr-util rpms and installed (./configure, make, make install) the ones that came with apache (/opt/httpd-2.2.11/srclib/apr and ../apr-util).

apr installed ok. Got errors on apr-util on make install as follows:

----------------------------------------------------------------------
/usr/bin/install -c -m 644 expat.h /usr/local/apr/include/apr-1
make[2]: Leaving directory `/opt/httpd-2.2.11/srclib/apr-util/xml/expat/lib'
make[1]: Leaving directory `/opt/httpd-2.2.11/srclib/apr-util/xml/expat'
/bin/sh /usr/local/apr/build-1/libtool --mode=install /usr/bin/install -c -m 755 libaprutil-1.la /usr/local/apr/lib
libtool: install: error: cannot install `libaprutil-1.la' to a directory not ending in /usr/local/apache2/lib
make: *** [install] Error 1
[root@localhost apr-util]#

Created the directory /usr/local/apache2 and got same error.

After installing /opt/httpd-2.2.11/srclib/openssl/openssl-0.9.8j tried to
see if apache will install with --enable-ssl option but got this error:

[root@localhost httpd-2.2.11]# ./configure --prefix=/usr/local/apache2 --enable-ssl
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu

Configuring Apache Portable Runtime library ...

checking for APR... yes
setting CC to "gcc"
setting CPP to "gcc -E"
setting CFLAGS to " -g -O2 -pthread"
setting CPPFLAGS to " -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE"
setting LDFLAGS to " "

Configuring Apache Portable Runtime Utility library...

checking for APR-util... reconfig
configure: error: Cannot use an external APR with the bundled APR-util

I am stuck at this point. Any help is appreciated.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 1692
Location: Sun Diego, CA, USofA

PostPosted: Wed 21 Jan '09 22:01    Post subject: Reply with quote

Since it is finding reminents of the apr package that at least was installed ...
maybe

--with-included-apr
or
--with-apr=/path/to/httpd-2.2.11/srclib/apr
--with-apri-util=/path/to/httpd-2.2.11/srclib/apr
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1