logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



modsecurity 2.9.1VC14 installation issues on easyphp 13.1

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
nasrallah.larech



Joined: 25 Apr 2016
Posts: 4
Location: algiers

PostPosted: Mon 25 Apr '16 14:55    Post subject: modsecurity 2.9.1VC14 installation issues on easyphp 13.1 Reply with quote

hi there. am having an issue on the installation modsecurity 2.9.1VC14 on easyphp 13.1 (apache:2.4.4, php:5.4.14, mysql:5.6.11).
though i followed the installation instructions given in the readme text file step by step, i couldn't get the apache server start (it crash all the time).
question: is there a compatibility version issues or i missed something here?

i looked to the apache log file and i found this line:
modsecurity: loaded PCRE do not match with compiled!
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 26 Apr '16 11:14    Post subject: Reply with quote

What error do you get in the Apache error.log and/or Windows Event Viewer ?

What do you get when at the command prompt at ../apache/bin you type:

> httpd -t

Where is Easyphp build with, also build with VC14 ?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Tue 26 Apr '16 16:46    Post subject: Reply with quote

Apache 2.4.4 was released on Feb 25, 2013. Somehow I doubt it was built with VC14 and more likely VC11 since Mysql 5.6 is VC11 and Easyphp 14.1 came in either VC9 or 11, I cannot find 13.1.

There is a VC11 build of mod_security 2.9.1 at The Apache Haus if this is what you're really needing.
Back to top
nasrallah.larech



Joined: 25 Apr 2016
Posts: 4
Location: algiers

PostPosted: Tue 26 Apr '16 22:04    Post subject: Reply with quote

hi thanks for your quick feedback. indeed my easyphp is older somehow and i am sure it s not built with VC14 so i ll give it a try with modsecurity VC11.
i ll return toward this post with the outcome of the deployment once done so others will benefit from this experience.

best regards
Back to top
nasrallah.larech



Joined: 25 Apr 2016
Posts: 4
Location: algiers

PostPosted: Mon 02 May '16 16:27    Post subject: modsecurity 2.9.1VC14 installation issues on easyphp 13.1 Reply with quote

well guys, i tried to install modsecurity VC11 on easyphp13.1VC9 and i get errors, following the guidance of steffen by executing the command of apache.exe -t (instead of hhtpd -t) i get the output below:
"
C:\Program Files\EasyPHP-DevServer-13.1VC11\binaries\apache\bin>apache.exe -t
AH00526: Syntax error on line 223 of C:/Program Files/EasyPHP-DevServer-13.1VC11/binaries/apache/conf/modsecurity.conf:
Could not open unicode map file "C:/Program Files/EasyPHP-DevServer-13.1VC11/binaries/apache/conf/unicode.mapping": Le fichier sp\xe9cifi\xe9 est introuvable.
"
meaning that the file sp\xe9cifi\xe9 wasn't found.

in the modsecurity.conf file line 223 the setting of the unicode.mapping is as follow: SecUnicodeMapFile unicode.mapping 20127.

any ideas or guidances instructions are more than welcome cause am stuck with this problem and am getting bit frustruated not being able to deploy such powerful tool.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Mon 02 May '16 17:00    Post subject: Reply with quote

See also https://www.apachelounge.com/viewtopic.php?t=6570
Back to top
nasrallah.larech



Joined: 25 Apr 2016
Posts: 4
Location: algiers

PostPosted: Tue 03 May '16 13:16    Post subject: modsecurity 2.9.1VC14 installation issues on easyphp 13.1 Reply with quote

thanks steffen for the link, it did helped me fix the problem so again thank you
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1