logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



2.4.28 fails to start :: mod_SSL errors

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 158
Location: Denver, CO USA

PostPosted: Tue 03 Oct '17 21:39    Post subject: Reply with quote

Regrettably, 2.4.28 is not working for me. I am getting mod_SSL errors (I am using mod_md for my LetsEncrypt SSL certs).

I copied 2.4.28 over 2.4.27 and left all the .CONF files in place from 2.4.27 and 2.4.28 fails to start as there are mod_SSL errors.

If I revert back to 2.4.27, all is fine. Maybe 2.4.28 is not ready for GA?

-S
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Tue 03 Oct '17 21:52    Post subject: Reply with quote

You using mod_md with the patched mod_ssl ?
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 158
Location: Denver, CO USA

PostPosted: Tue 03 Oct '17 22:02    Post subject: Reply with quote

Yes I am using mod_md 0.9.2 with patched SSL.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 03 Oct '17 22:36    Post subject: Reply with quote

Added the latest mod_md build with 2.4.28 to the download at

https://www.apachelounge.com/viewtopic.php?p=35891 (Do not forget to copy the mod_ssl)

What error you get ?
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 158
Location: Denver, CO USA

PostPosted: Tue 03 Oct '17 22:44    Post subject: Reply with quote

Steffen:

I went and copied in the mod_SSL (patched v5) from the mod_md download and that solved the issue.

-S
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 03 Oct '17 22:46    Post subject: Reply with quote

You running now 0.9.7 ?
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 158
Location: Denver, CO USA

PostPosted: Tue 03 Oct '17 22:53    Post subject: Reply with quote

Steffen,

After your initial post, I reverted back to the V5 patched mod_ssl in mod_md 0.9.6, and that worked.

I then saw you posted mod_md 0.9.7, so I downloaded and applied that to my 2.4.28 install, and all is working wonderfully.

Thank you for the guidance, much appreciated.

-S
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1