logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



Win32DisableAcceptEx, EnableMMAP, EnableSendfile - when/why?

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
pash_ka



Joined: 16 Dec 2005
Posts: 4
Location: Moscow, Russia

PostPosted: Thu 02 Feb '06 19:27    Post subject: Win32DisableAcceptEx, EnableMMAP, EnableSendfile - when/why? Reply with quote

There is a common recomendation to use Win32DisableAcceptEx, EnableMMAP, EnableSendfile directives when one encounters a problem with strange error messages, etc.
It is said in the docs, that this is needed on some OS/configs and nobody says where and why should man use these options.

Is there a list of OS/Software/Hardware that requires them?

On my server i have Win2000 Server (with latest SP and updates) and no antivirus/soft. firewall. It is placed behind the NAT.
The average server load is 10-30 requests per second.
Apache version is 2.0.55. I'm also using PHP 5.1.2 loaded as module.

I had to use Win32DisableAcceptEx and EnableSendfile Off options.
Without Win32DisableAcceptEx i have
"[warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed." errors.
Can i do something to enable AcceptEx or it can't work with NAT?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2160
Location: Hilversum, NL, EU

PostPosted: Fri 03 Feb '06 14:43    Post subject: Reply with quote

I am dealing with the same here (with Apache 2.0.55 and 2.2.0). Do not know if it has something to do with NAT. It is discussed more times on the Apache IRC, but no one knows the answer.

I have now:

Win32DisableAcceptEx on
EnableSendfile off
EnableMMAP off

I have still in the logs the message, but with this setting Apache does not stops responding once in a while. When I set Win32DisableAcceptEx to off, the Apache memory usage grows.

Steffen
Back to top
pash_ka



Joined: 16 Dec 2005
Posts: 4
Location: Moscow, Russia

PostPosted: Fri 03 Feb '06 15:00    Post subject: Reply with quote

Hello Steffen!
Do you still have "Asynchronous AcceptEx failed" errors in logs, or some others?
If they are "AcceptEx", you can try to write "Win32DisableAcceptEx" instead of "Win32DisableAcceptEx on".

In my logs there are only "erealloc(): Unable to allocate N bytes" errors now and they happen usualy then i send restart signal (via "apache -k restart" command). There are some strange restarts also, but not too often.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2160
Location: Hilversum, NL, EU

PostPosted: Fri 03 Feb '06 15:55    Post subject: Reply with quote

I have only with the above settings in the log:

[warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.

Despite of this warning all works fine.

Sometimes I have the feeling it has something to do with my ISP connection.

Never seen here you message: erealloc(): Unable to allocate N bytes . When I recall, I had a report of a user where the cause was PHP (script), which was calling a external program (.exe).

Steffen
Back to top
pash_ka



Joined: 16 Dec 2005
Posts: 4
Location: Moscow, Russia

PostPosted: Fri 03 Feb '06 16:11    Post subject: Reply with quote

In my scripts I do call external program sometimes, but I dont think it is connected since it happens very seldom (once or twice per week) and erealloc() errors are almost at every restart.

Do you know if there is something I can do to find the source of this errors?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2160
Location: Hilversum, NL, EU

PostPosted: Fri 03 Feb '06 16:59    Post subject: Reply with quote

Maybe you can try "LogLevel debug" and in php.ini "error_reporting = E_ALL"

Steffen
Back to top
pash_ka



Joined: 16 Dec 2005
Posts: 4
Location: Moscow, Russia

PostPosted: Fri 03 Feb '06 17:04    Post subject: Reply with quote

Thanks. I will try it.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1