Apache Lounge



Forum Index Downloads Search Register Log in  RSS Apache Lounge

Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.



A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.

Vintage custom perl modules hanging in Apache 2.2.16

Post new topic   Reply to topic    Apache Forum Index -> Coding & Scripting Corner

View previous topic :: View next topic  
Author Message

Joined: 07 May 2015
Posts: 1
Location: Boston, MA

PostPosted: Thu 07 May '15 16:32    Post subject: Vintage custom perl modules hanging in Apache 2.2.16 Reply with quote

I inherited an intranet that runs on a Windows Server 2008, Apache 2.0.64, Active Perl 5.6.0 environment. Someone in 2000 had written custom perl modules to hit our proprietary database and supply the intranet with data. I wanted to add an intranet that hit our SQL Server, so I built on a separate Windows Server 2003 box an Apache 2.2.16, Strawberry Perl 5.12, SQL Server 2005 intranet.
I have been trying to get this SQL intranet to work with the old custom Perl modules and my test cgi keeps hanging when I run it through Apache, but solves correctly when run through the command line. I have debugged it to the point where I know that it hangs when the Perl Win32::API module blesses the new database object and tries to return it to the custom database module. I have tried to put in all of the STDERR fixes I have read online and they have not helped. Does anybody have any ideas?

The custom perl module starts like this:
package Prop::Database
use Win32::API;
use Carp;
my $OpenTopic = new Win32::API("abcde32","OpenTopic",[P, P],N);

and continues until it dies around:
$lpTopic = pack("L",0);
$Topic = pack("a64",$topic);
$return = $OpenTopic->Call($Topic, $lpTopic);

at this point it goes to Win32::API module and never returns. In the apache error log it reads the old "(70007)The timeout specified has expired: ap_content_length_filter: apr_bucket_read() failed". This script solves and runs in a second from the command line. Thanks in advance for any thoughts!
Back to top

Joined: 15 Oct 2005
Posts: 2683
Location: Hilversum, NL, EU

PostPosted: Fri 08 May '15 9:49    Post subject: Reply with quote

Better to ask the https://perl.apache.org/maillist/modperl.html
Back to top

Post new topic   Reply to topic    Apache Forum Index -> Coding & Scripting Corner
Page 1 of 1