Apache Lounge


About Forum Index Downloads Search Register Log in RSS X

Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.



A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Hardware & Networking View previous topic :: View next topic
Reply to topic   Topic: Port 80 Stopped Working

Joined: 21 Oct 2016
Posts: 5
Location: London

PostPosted: Tue 24 Apr '18 13:40    Post subject: Port 80 Stopped Working Reply with quote

Firstly, apologies if this is in the wrong topic or even forum, this would be because I don't know what exactly is causing the problem.

My hobby website running with Apache and Windows 10 from my laptop was working fine until a few days ago I think after accidentally powering off the laptop and router via the power plug. Since then, the website has not been responding.

Today I managed to get the site working by changing the line in httpd.conf from "Listen 80" to a different port e.g 8000, but the problem with this is I seem to have to use ":8000" at the end of all addresses to access the site e.g localhost:8000, etc which is not ok as the the IPv4 address field for the remote service I use to forward traffic from the domain name to my laptop will not accept : characters.

Also it is baffling me as to why I cannot use port 80 anymore because the Apache service will start on the host machine listening on port 80, Windows Firewall seems to be completely switched off, and if I run the command "netstat -anb | find ":80" in a cmd window I only get two results both of which seem to be from httpd.exe ;

TCP [::]:80 [::]:0 LISTENING

I have tried using two different routers and get the same problem with both so I don't think that is the cause. Any advice would be really appreciated as I have been struggling with the problem for days now. Kind Regards.
Back to top

Joined: 21 Oct 2016
Posts: 5
Location: London

PostPosted: Wed 25 Apr '18 10:42    Post subject: Reply with quote

Ok so this morning I realised that if I accessed localhost/index.php in the browser address bar, that worked as opposed to just localhost which gave me a time out error.

I could find nothing in the httpd.conf file that explained why this was happening, i.e it was all set to take the user to index.php if they accessed the root as far as I could see i.e even if I replaced httpd.conf with the original/default from the conf\original folder the problem still occurred.

Eventually I decided to reinstall Apache but even after that the problem was occurring. Then I tried in a browser other than Chrome and hey presto, just typing localhost in the address bar took me to index.php as expected. Then I cleared all the cookies and cache in Chrome and it started working in that browser as well. So not sure what was causing the problem but it seems to be fixed now.
Back to top

Reply to topic   Topic: Port 80 Stopped Working View previous topic :: View next topic
Post new topic   Forum Index -> Hardware & Networking