logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> How-to's & Documentation & Tips View previous topic :: View next topic
Reply to topic   Topic: HOWTO: Building Apache and dependencies using CMake Page Previous  1, 2
Author
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Fri 14 Jan '22 14:21    Post subject: Reply with quote

- Bump batch file code for package release updates:
    CURL (7.81.0)
    EXPAT (2.4.2)
- Change LUA option LUA_COMPAT_ALL to LUA_COMPAT_5_3.
- Patch APR (1.7.0) for handle leak (PR 61165 [Ivan Zhakov]). Notable impact with ModSecurity.
- Refine some of the Perl patch edit code.
- Update VCVARSALL script path for MS Visual Studio 2022 (VS17).

After investigating the assembler code options with ZLIB, mentioned above by Steffen, have decided to not include an option for it. As it stands, the CMakeLists.txt file for ZLIB 1.2.11 has logic to support this assembler feature, but is missing a reference to compile contrib\masmx64\inffas8664.c. With that added, the 64 bit version builds and works fine, but the 32 bit version generates a segfault. For those interested, the last entry at the following Stackoverflow page details this problem, and a GitHub patch workaround (https://stackoverflow.com/questions/29505121/cmake-zlib-build-on-windows). Nonetheless, since this is an optional speed enhancement, we stick with the official release without the assembler code.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Sat 19 Mar '22 17:32    Post subject: Reply with quote

These updates match Steffen's 2.4.53 release built using PCRE2, plus the option to use OpenSSL3.

Other than release version details, there are no changes to the batch file build logic. Details are:

- Bump batch file code for recent package release updates:

CURL (7.82.0)
EXPAT (2.4.7)
HTTPD (2.4.53)
LUA (5.4.4)
NGHTTP2 (1.47.0)
OPENSSL (1.1.1n/3.0.2)
PCRE2 (10.39)

- Provide option to build PCRE2 (default) rather than PCRE
- Provide option to build OpenSSL3 rather than OpenSSL (default)


Last edited by tangent on Thu 10 Nov '22 13:12; edited 1 time in total
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1258
Location: Amsterdam, NL, EU

PostPosted: Sat 19 Mar '22 17:39    Post subject: Reply with quote

LUA 5.4.4? Should not that be LUA 5.2.4?
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Sat 19 Mar '22 17:50    Post subject: Reply with quote

For my sins, I've been building with LUA 5.4 series for some time. Only just realised Steffen's site build uses LUA 5.2, as you point out.

I'll leave it at 5.4.x unless there's a specific reason to downgrade it. Users can always choose what package versions they want anyway, if there's a dependency.


Last edited by tangent on Thu 10 Nov '22 13:12; edited 1 time in total
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Mon 13 Jun '22 22:35    Post subject: Reply with quote

These updates match Steffen's 2.4.54 release changes, using PCRE2 plus the option to use OpenSSL3.

Other than release version details, there are no changes to the batch file build logic from before. Release details are:

CURL (7.83.1)
EXPAT (2.4.8)
HTTPD (2.4.54)
LIBXML2 (2.9.14)
OPENSSL (1.1.1o/3.0.3)
PCRE2 (10.40)
ZLIB (1.2.12)


Last edited by tangent on Thu 10 Nov '22 13:11; edited 1 time in total
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Thu 10 Nov '22 13:09    Post subject: Reply with quote

Build dependency updates to match Steffen's recent release changes:

CURL (7.86.0)
EXPAT (2.5.0)
LIBXML2 (2.10.3)
OPENSSL (1.1.1s/3.0.7)
ZLIB (1.2.13)

Also switch the build default to OpenSSL V3 series.
Set option for CURL default SSL backend to Schannel rather than OpenSSL.
Note you can change the SSL backend at run time with environment variable CURL_SSL_BACKEND.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Sun 05 Feb '23 20:25    Post subject: Reply with quote

Build dependency updates to match Steffen's recent 2.4.55 release changes:

APR (1.7.2)
APR-UTIL (1.6.3)
CURL (7.87.0)
HTTPD (2.4.55)
NGHTTP2 (1.51.0)
PCRE2 (10.4.2)

Note, above build batch file logic has been updated to remove previous APR point patches.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Wed 08 Mar '23 17:07    Post subject: Reply with quote

Build dependency updates to match Steffen's recent 2.4.56 release changes:

CURL (7.88.1)
HTTPD (2.4.56)
NGHTTP2 (1.52.0)
OPENSSL(1.1.1t/3.0.8)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Fri 12 May '23 17:31    Post subject: Reply with quote

Build dependency updates to match Steffen's recent 2.4.57 release changes:

APR (1.7.4)
CURL (8.0.1)
HTTPD (2.4.57)
LIBXML2 (2.11.2)
OPENSSL(1.1.1t/3.1.0)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Thu 10 Aug '23 22:21    Post subject: Reply with quote

Build dependency updates to match Steffen's latest 2.4.57 release changes:

CURL (8.2.1)
LIBXML2 (2.11.5)
LUA (5.4.6)
NGHTTP2 (1.55.1)
OPENSSL(1.1.1v/3.1.2)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Fri 20 Oct '23 16:21    Post subject: Reply with quote

Build dependency updates to match Steffen's latest 2.4.58 release changes:

BROTLI (1.1.0)
CURL (8.4.0)
HTTPD (2.4.58)
NGHTTP2 (1.57.0)
OPENSSL(1.1.1w/3.1.3)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top
kimboslice



Joined: 30 Nov 2022
Posts: 4
Location: Canada

PostPosted: Thu 11 Jan '24 22:26    Post subject: OpenSSL build fails Reply with quote

Having some issues getting openssl to build

Code:
Building openssl-3.1.3
Can't locate Locale/Maketext/Simple.pm in @INC (you may need to install the Locale::Maketext::Simple module) (@INC contains: /c/Apache24/src/openssl-3.1.3/util/perl /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /c/Apache24/src/openssl-3.1.3/external/perl/Text-Template-1.56/lib) at /usr/share/perl5/core_perl/Params/Check.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/Params/Check.pm line 6.
Compilation failed in require at /usr/share/perl5/core_perl/IPC/Cmd.pm line 59.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/IPC/Cmd.pm line 59.
Compilation failed in require at /c/Apache24/src/openssl-3.1.3/util/perl/OpenSSL/config.pm line 19.
BEGIN failed--compilation aborted at /c/Apache24/src/openssl-3.1.3/util/perl/OpenSSL/config.pm line 19.
Compilation failed in require at Configure line 23.
BEGIN failed--compilation aborted at Configure line 23.
perl configure for openssl-3.1.3 failed with status 2


There is no folder named locale in the source code of openssl 3.1.3, have I downloaded the wrong source? Confused

Edit: solved, issue was I had perl somewhere else, just move the paths created by Strawberry Perl to the top of your environment variables
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Thu 11 Jan '24 23:08    Post subject: Reply with quote

Your problem isn't with OpenSSL, but rather your Perl installation doesn't include the locale/Maketext/Simple.pm module, as indicated by the first line of your log messages.

This module comes as standard with the Strawberry Perl I build with on Windows, but you should be able to install it using CPAN.

Check for it's presence from the command line with the following, which should produce no output.

Code:
perl -Mlocale::Maketext::Simple -e ';'
Back to top
kimboslice



Joined: 30 Nov 2022
Posts: 4
Location: Canada

PostPosted: Fri 12 Jan '24 20:56    Post subject: Reply with quote

I believe theres a small error in the script, you show the folder structure as having pcre-10.42 but the script looks for pcre2-10.42
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Fri 12 Jan '24 21:48    Post subject: Reply with quote

Thank you for this pointing out.

The error was in the view of the folder structure, not the script per se, and arose when the build default was updated from PCRE to PCRE2
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Sun 04 Feb '24 21:33    Post subject: Reply with quote

Build dependency updates to match Steffen's recent 2.4.58 release changes:

CURL (8.6.0)
LIBXML2 (2.12.5)
NGHTTP2 (1.59.0)
OPENSSL (3.1.5)
ZLIB (1.3.1).

Also update build batch file to patch HTTPD ApacheMonitor.rc file to comment out MANIFEST file reference, which otherwise causes a duplicate resource cvtres/link error following recent updates to VS2022.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Fri 05 Apr '24 20:34    Post subject: Reply with quote

Build dependency updates to match Steffen's latest HTTPD 2.4.59 release changes:

CURL (8.7.1)
EXPAT (2.6.2)
HTTPD (2.4.59)
LIBXML2 (2.12.6)
NGHTTP2 (1.61.0)
PCRE2 (10.43)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top
tangent
Moderator


Joined: 16 Aug 2020
Posts: 327
Location: UK

PostPosted: Sat 08 Jun '24 11:36    Post subject: Reply with quote

Build dependency updates to match Steffen's latest HTTPD 2.4.59 release changes:

CURL (8.8.0)
HTTPD (2.4.59)
LIBXML2 (2.12.7)
NGHTTP2 (1.62.1)
OPENSSL (3.1.6)
PCRE2 (10.44)

Other than release version details, there are no changes to the batch file build logic from before.
Back to top


Reply to topic   Topic: HOWTO: Building Apache and dependencies using CMake View previous topic :: View next topic
Post new topic   Forum Index -> How-to's & Documentation & Tips Page Previous  1, 2