logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: .htaccess not being read by server
Author
msaz87



Joined: 07 Jul 2006
Posts: 16

PostPosted: Fri 07 Jul '06 4:49    Post subject: .htaccess not being read by server Reply with quote

Hey,

I'm trying to switch a site over from a server hosted by lunarpages to my own server. I recently installed Apache 2.2/php/mysql on this server... but have some configuration needing to be done.

My problem is that the server doesn't seem to be reading my .htaccess files. Here's the .htaccess code:
Code:
Options +Indexes
   IndexOptions FancyIndexing SuppressDescription SuppressHTMLPreamble
   HeaderName header.htm
   ReadmeName footer.htm
   IndexIgnore header.htm footer.htm .htaccess direclogo.gif


My goal is to add style to the auto-generated index pages.

I'm unsure of whether there is something set in my httpd.conf that is disabling or overruling the .htaccess. Also, there is a httpd-autoindex.conf in my conf/default directory. That reads:
Code:
#
# Directives controlling the display of server-generated directory listings.
#
# Required modules: mod_autoindex, mod_alias
#
# To see the listing of a directory, the Options directive for the
# directory must include "Indexes", and the directory must not contain
# a file matching those listed in the DirectoryIndex directive.
#

#
# IndexOptions: Controls the appearance of server-generated directory
# listings.
#
IndexOptions FancyIndexing HTMLTable VersionSort

Alias /icons/ "C:/Program Files/Apache Software Foundation/Apache2.2/icons/"

<Directory "C:/Program Files/Apache Software Foundation/Apache2.2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

# HeaderName is the name of a file which should be prepended to
# directory indexes.
ReadmeName README.html
HeaderName HEADER.html

#
# IndexIgnore is a set of filenames which directory indexing should ignore
# and not include in the listing.  Shell-style wildcarding is permitted.
#
IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t


This is my first server i've set up... so everything is still very new to me.

If you guys have any ideas, i'd love to hear them.

Thanks.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7104
Location: Germany, Next to Hamburg

PostPosted: Fri 07 Jul '06 9:38    Post subject: Reply with quote

Use the autogeneratet httpd.conf and put in the directority which shuld have that new design a HEADER.html In the HEADER.html put your style content
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2930
Location: Hilversum, NL, EU

PostPosted: Fri 07 Jul '06 14:03    Post subject: Reply with quote

You have: AllowOverride None, that means .htaccess files are completely ignored. The server will not even attempt to read .htaccess files in the filesystem.

See: http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

Steffen
Back to top
msaz87



Joined: 07 Jul 2006
Posts: 16

PostPosted: Sun 09 Jul '06 21:44    Post subject: Reply with quote

Perfect. Worked like a charm. Thank you very much.

Do you know how to have icons show up as well for the directories?

Thanks.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7104
Location: Germany, Next to Hamburg

PostPosted: Sun 09 Jul '06 22:56    Post subject: Reply with quote

If in the diretority is no index file Apache will create a list with the icons itself. example
or do you want to assosoate a specific file with an icon?
Back to top
msaz87



Joined: 07 Jul 2006
Posts: 16

PostPosted: Mon 10 Jul '06 8:57    Post subject: Reply with quote

Well, i'm guessing i have something set in my httpd.conf that disables icons... just like i had the AllowOverride disabled.

When my pages are generated, no icons appear.

Do you guys know what might be the problem?

Thanks.
Back to top


Reply to topic   Topic: .htaccess not being read by server View previous topic :: View next topic
Post new topic   Forum Index -> Apache