logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache/2.0.63 and mod_ssl/0.98g issue
Author
jhemcy



Joined: 12 Mar 2008
Posts: 1

PostPosted: Fri 14 Mar '08 3:41    Post subject: Apache/2.0.63 and mod_ssl/0.98g issue Reply with quote

Hi,
I am trying to upgrade from Apache/2.0.59 & mod_ssl/0.98g to Apache/2.0.63 & mod_ssl/0.98g. Some conditions (applications) do not allow me to upgrade to Apache/2.2.x at this point. The system is running on Windows 2003.

I downloaded and installed the apache_2.0.63-win32-x86-openssl-0.9.7m.msi from Apache's site. I then copied my httpd.conf and ssl.conf over. I also installed mod_ssl/0.98 (downloaded on this site a few weeks ago) by overwriting the openssl.exe and the 2 dll files (including libeay32.dll).

The Apache service fails to start and the message given is: "Could not start the Apache2 service on local computer. Error 1067: The proces terminated unexpectedly". The last line of the ssl.log file displays: "mod_ssl/2.0.63 compiled against server Apache/2.0.63, Library: openSSL/0.97m".

I would like to know if anyone has an idea on how to fix this issue, or can point me to a site where I could download Apache 2.0.63 and mod_ssl 0.98g (latest releases for both Apache 2.0.x and mod_ssl)?

Thanks,

James
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2767
Location: Hilversum, NL, EU

PostPosted: Fri 14 Mar '08 8:34    Post subject: Reply with quote

I assume that it is working with openSSL/0.97m.

Any more info in the Windows Event Viewer ?

Steffen
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Fri 14 Mar '08 15:13    Post subject: Reply with quote

Apache 2.2 can work with OpenSSL 0.9.8, but Apache 2.0 can only work with OpenSSL 0.9.7.

The latest release of OpenSSL 0.9.7 is version 0.9.7m - which is the version included with Apache 2.0.

Maybe you thought you could install the OpenSSL 0.9.8g download for Apache 2.2 and get it to work with Apache 2.0?
I don't think you can do this.

You could recompile Apache 2.0.63 from the source code to use OpenSSL 0.9.8. See this post for some info about how to do this.

-tom-
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2212
Location: Sun Diego, USA

PostPosted: Fri 14 Mar '08 17:55    Post subject: Reply with quote

I should read your full response before I open my mouth Embarassed
-deleted-
Back to top


Reply to topic   Topic: Apache/2.0.63 and mod_ssl/0.98g issue View previous topic :: View next topic
Post new topic   Forum Index -> Apache