logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



The Requested Operation has Failed

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
bilalrj



Joined: 23 Dec 2008
Posts: 6
Location: pakistan

PostPosted: Wed 31 Dec '08 10:53    Post subject: The Requested Operation has Failed Reply with quote

HI,
I have Following Problem. Any one know how to solve this problem please guide me. I am using oracle and apache on windows server 2003. When i try to start it by apache monitor it generate error msg "The Requested Operation has Failed".

"Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator.G-SERV.000>httpd.exe -e debug
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module actions_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module alias_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module asis_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module auth_basic_modul
e
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authn_default_mo
dule
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authn_file_modul
e
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authz_default_mo
dule
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authz_groupfile_
module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authz_host_modul
e
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module authz_user_modul
e
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module autoindex_module

[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module dir_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module env_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module info_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module isapi_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module log_config_modul
e
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module mime_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module negotiation_modu
le
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module rewrite_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module setenvif_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module status_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module userdir_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module cgi_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file php\\bin\\php5ts.d
ll
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file php\\bin\\fdftk.dl
l
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file D:/apache2triad/my
sql/bin/libmysql.dll
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module php5_module
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file php\\bin\\ntwdblib
.dll
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file perl\\bin\\perl58.
dll
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(325): loaded file python\\bin\\pytho
n23.dll
[Wed Dec 31 13:47:59 2008] [debug] mod_so.c(246): loaded module include_module
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\Documents and Settings\Administrator.G-SERV.000>
"
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6472
Location: Germany, Next to Hamburg

PostPosted: Thu 01 Jan '09 21:28    Post subject: Reply with quote

It seems that a program is listen on port 80 or a firewall blocks that port.

You can run netstat -ab to see if there is a program listen on that port.
Back to top
bilalrj



Joined: 23 Dec 2008
Posts: 6
Location: pakistan

PostPosted: Fri 02 Jan '09 11:24    Post subject: Reply with quote

Hi James Blond
This is result when I execute netstat -ab command. Please tell me what is wrong here.
"Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator.G-SERV.000>netstat -ab

Active Connections

Proto Local Address Foreign Address State PID
TCP g-serv:ftp g-serv:0 LISTENING 912
[SlimFTPd.exe]

TCP g-serv:smtp g-serv:0 LISTENING 1188
[XMail.exe]

TCP g-serv:finger g-serv:0 LISTENING 1188
[XMail.exe]

TCP g-serv:http g-serv:0 LISTENING 1816
[httpd.exe]

TCP g-serv:pop3 g-serv:0 LISTENING 1188
[XMail.exe]

TCP g-serv:epmap g-serv:0 LISTENING 948
RpcSs
[svchost.exe]

TCP g-serv:microsoft-ds g-serv:0 LISTENING 4
[System]

TCP g-serv:1025 g-serv:0 LISTENING 660
[lsass.exe]

TCP g-serv:1033 g-serv:0 LISTENING 444
[ORACLE.EXE]

TCP g-serv:1521 g-serv:0 LISTENING 1928
[omtsreco.exe]

TCP g-serv:2100 g-serv:0 LISTENING 364
[TNSLSNR.exe]

TCP g-serv:ms-wbt-server g-serv:0 LISTENING 3028
TermService
[svchost.exe]

TCP g-serv:6017 g-serv:0 LISTENING 1188
[XMail.exe]

TCP g-serv:8080 g-serv:0 LISTENING 364
[TNSLSNR.exe]

TCP g-serv:netbios-ssn g-serv:0 LISTENING 4
[System]

TCP g-serv:1521 g-serv:0 LISTENING 364
[TNSLSNR.exe]

TCP g-serv:1748 g-serv:0 LISTENING 348
[dbsnmp.exe]

TCP g-serv:1754 g-serv:0 LISTENING 348
[dbsnmp.exe]

TCP g-serv:1808 g-serv:0 LISTENING 348
[dbsnmp.exe]

TCP g-serv:1809 g-serv:0 LISTENING 348
[dbsnmp.exe]
"
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6472
Location: Germany, Next to Hamburg

PostPosted: Fri 02 Jan '09 11:54    Post subject: Reply with quote

If that is the full list from netstat -ab there is no program listen on your port 80. So I guess You have a firewall?
Back to top
bilalrj



Joined: 23 Dec 2008
Posts: 6
Location: pakistan

PostPosted: Sat 03 Jan '09 12:51    Post subject: Reply with quote

Hi James Blond,
I check firewall in my system but there is not firewall expect window default firewall but that firewall is off. Now i try to install WAMP5 and enable oracle extension this time apache is running but not enabling oracle extension.If you have any idea about this problem please guide me.
Thankx in advance
Back to top
labbams4u



Joined: 04 Apr 2013
Posts: 1
Location: India, Bangalore

PostPosted: Thu 04 Apr '13 21:07    Post subject: Re: Apache requested operation has failed Reply with quote

if apache is not starting and getting error "Requested operation failed"

go to the command prompt : services.msc
search for Apache> right click and select properties.
In the General tab one startup type drop down is there. Change it to Automatic and click Apply.
Then Start button will get enabled.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2170
Location: Sun Diego, USA

PostPosted: Fri 05 Apr '13 0:23    Post subject: Reply with quote

Disabling the firewall locks things in place. Enable firewall, then in the exceptions tab check the things you want to let through. You could also add the httpd.exe to from the add programs button in exceptions. This has the advantage of opening all the ports Apache is listening to.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1