logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



SOLVED: php_curl.dll crashing Apache

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Fri 15 Oct '10 15:43    Post subject: SOLVED: php_curl.dll crashing Apache Reply with quote

Hello all the clever people. I have an installation of Apache 2.2.16, PHP 5.2.14, MySQL 5.1.51 and Zend Optimizer 3.3.3 running on Windows XP SP3 in Vmware. When PHP is running only these extensions - BZ2, GD2, GETTEXT, IMAP, MBSTRING, MYSQL, MYSQLi, OPENSSL, PDO MYSQL, PDO ODBC, PDO SQLITE, PGSQL, SOAP, SOCKETS, SQLITE, TIDY, XMLRPC, and EXIF, everything is working fine. But whenever I uncomment php_curl.dll extension and restart the Apache I get a very well known error: Unable to load dynamic library php_curl.dll bla bla...I have just looked everywhere on the internet for the solution and I tried them all. php_curl.dll is available in ext directory of PHP. ssleay32.dll and libeay32.dll exist in PHP root directory and PHP root directory is in the system path. I tried to copy ssleay32.dll, libeay32.dll, php5ts.dll to System32 as some people suggested bit it does not help. I tried to to copy them to Apache/bin directory, but it did not help too. I also tried to install Apache 2.2.15, it did not help. I tried both manual and installer install with the same result. Does anyone have any other idea, which could help me to make it run. I do not want PHP 5.3.3, I need PHP 5.2.X because of Zend Optimizer which is only running with PHP 5.2.X. Thank you for any help on this issue.

Last edited by Anaxagoras on Mon 25 Oct '10 13:21; edited 1 time in total
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 20 Oct '10 10:12    Post subject: Reply with quote

Which version of PHP do you use? Thread safe? Non thread safe? VC6? VC9? PHP as module or over fcgid?
Back to top
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Wed 20 Oct '10 10:15    Post subject: Reply with quote

I am using VC6 thread safe version of course and PHP as a module. I have finaly solved it by copying php_curl.dll library from PHP 5.2.13 to ext folder of PHP 5.2.14 and it started to work. So it looks there is a problem with php_curl.dll library in PHP 5.2.14.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 20 Oct '10 10:29    Post subject: Reply with quote

Feel free to report that bug at http://bugs.php.net/. Before insert it make sure there isn't a report of that yet Wink
Back to top
lafutura



Joined: 21 Oct 2010
Posts: 3

PostPosted: Thu 21 Oct '10 0:08    Post subject: WOW!!! Reply with quote

i cannot tell you how much of a headache i have from having fought with this issue all day long. most of the posts i find via google were completely useless as i already had the associated dlls in the right places, had uncommented the extension in the right place, etc.

finding 5.2.13 and installing the php_curl.dll out of that worked! ohhhhh my goodness. i could kiss you!

i did try to use the php_curl.dll out of 5.3 and it didn't work for me, so it seems as if whatever the issue was with 5.2.14 has carried on.

thank you thank you thank you!!!
Back to top
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Thu 21 Oct '10 8:20    Post subject: Reply with quote

I am glad I could help Smile I was seriously getting crazy of this bug...
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 21 Oct '10 9:58    Post subject: Re: WOW!!! Reply with quote

lafutura wrote:

i did try to use the php_curl.dll out of 5.3 and it didn't work for me, so it seems as if whatever the issue was with 5.2.14 has carried on.


There are a lot of changes from 5.2 to 5.3 like from 4 to 5.0 Wink None of the extension from 5.3 will load into 5.2
Back to top
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Thu 21 Oct '10 12:51    Post subject: Reply with quote

I would post a bug at PHP.net about this issue but it needs some kind of patch name and patch file and I do not know how and where to get it...

EDIT: solved Smile
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 21 Oct '10 13:22    Post subject: Reply with quote

Even if you can't offer a patch it is good to post that bug.
Back to top
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Thu 21 Oct '10 13:24    Post subject: Reply with quote

It has been posted before me Smile But I do not how the search in bugs works, because I could not found that, so I posted duplicate Sad

http://bugs.php.net/bug.php?id=53125
http://bugs.php.net/bug.php?id=52905
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 21 Oct '10 14:13    Post subject: Reply with quote

I wonder. Didn't you download your php from windows.php.net?
Back to top
Anaxagoras



Joined: 15 Oct 2010
Posts: 6
Location: Prague

PostPosted: Thu 21 Oct '10 14:17    Post subject: Reply with quote

Nope I have downloaded PHP 5.2.14 directly from php.net pages. Where is the difference?
Back to top
lafutura



Joined: 21 Oct 2010
Posts: 3

PostPosted: Thu 21 Oct '10 16:09    Post subject: Reply with quote

if it is of any interest to you, i did download mine via windows.php.net. also vc6 thread safe.

and interestingly this was the first time i had seen mention of it. granted i was using google to try to find documented problems, but still... and i did search on php.net but must have been putting in the wrong information as i couldn't come up with what i was looking for.

and my head no longer hurts, thanks to you. Smile
Back to top
lafutura



Joined: 21 Oct 2010
Posts: 3

PostPosted: Thu 21 Oct '10 21:14    Post subject: Reply with quote

Quote:
There are a lot of changes from 5.2 to 5.3 like from 4 to 5.0 None of the extension from 5.3 will load into 5.2


well, there goes my theory about the bug extending past 5.2.14. Smile
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Fri 22 Oct '10 1:34    Post subject: Reply with quote

Anaxagoras wrote:
Nope I have downloaded PHP 5.2.14 directly from php.net pages. Where is the difference?


I don't know what the difference might be. At least PHP 5.3 can be only downloaded from windows.php.net
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1