logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



eAccelerator NEW VERSIONS For PHP 5.3.3 and PHP 5.2.14

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
Millennium



Joined: 17 Apr 2006
Posts: 179
Location: Leiderdorp, NL, EU

PostPosted: Mon 26 Jul '10 21:49    Post subject: eAccelerator NEW VERSIONS For PHP 5.3.3 and PHP 5.2.14 Reply with quote

NEW VERSIONS For PHP 5.3.3 and PHP 5.2.14

SVN 425: Fix for ticket #431 (Optimizer)


PHP 5.2.14 VC6:
http://eac.qme.nl/eAccelerator_v1_0_svn425_for_v5_2_14-VC6.zip

PHP 5.3.3 VC6:
http://eac.qme.nl/eAccelerator_v1_0_svn425_for_v5_3_3-VC6.zip

PHP 5.3.3 VC9:
http://eac.qme.nl/eAccelerator_v1_0_svn425_for_v5_3_3.zip
Back to top
ileadu



Joined: 05 Dec 2008
Posts: 19

PostPosted: Tue 27 Jul '10 5:39    Post subject: Reply with quote

while i use VC9 version, apache cannot start.

VC6 version works.

Thanks.

How do you remove the warning of compile eaccelerator ?

I download official file, but cannot compile successful.
Back to top
Millennium



Joined: 17 Apr 2006
Posts: 179
Location: Leiderdorp, NL, EU

PostPosted: Tue 27 Jul '10 8:26    Post subject: Reply with quote

Warnings aren't fatal for an succesfull compile.


The 5.3.3 VC9 nts works fine here.
Back to top
ileadu



Joined: 05 Dec 2008
Posts: 19

PostPosted: Tue 27 Jul '10 18:00    Post subject: Reply with quote

http://windows.php.net/download/

Which version do I choose?
If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP

If you are using PHP with IIS you should use the VC9 versions of PHP

VC6 Versions are compiled with the legacy Visual Studio 6 compiler

VC9 Versions are compiled with the Visual Studio 2008 compiler and have improvements in performance and stability. The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed

Do NOT use VC9 version with apache.org binaries
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 27 Jul '10 20:28    Post subject: Reply with quote

Millennium,

I placed a link to this thread on the download page.


Thanks for making available for all of us, it runs fine here.

Steffen
Back to top
ileadu



Joined: 05 Dec 2008
Posts: 19

PostPosted: Sun 22 Aug '10 17:29    Post subject: Reply with quote

08/10/10:

22:46 Ticket #438 (Crash with php 5.3.3 on EL-5) closed by Millennium


Millennium is an eAccelerator developer ?
Back to top
Millennium



Joined: 17 Apr 2006
Posts: 179
Location: Leiderdorp, NL, EU

PostPosted: Tue 31 Aug '10 16:26    Post subject: Reply with quote

No I am not.

Just submitting bugs / patches and do some win32 compiling
Back to top
ileadu



Joined: 05 Dec 2008
Posts: 19

PostPosted: Sun 05 Sep '10 18:47    Post subject: Reply with quote

When I test performance of eaccelerator SVN425 and APC 3.1.4, I find that apc is better than eaccelerator now.

I use "ab -t 30 -c 10 http://127.0.0.1/blahblah.php" and compare their requests per second.

Is APC really better ?

http://downloads.php.net/pierre/
Back to top
wavetrex



Joined: 30 Jun 2010
Posts: 3
Location: Romania

PostPosted: Sat 06 Nov '10 17:46    Post subject: Works Reply with quote

The latest Apache 2.2.17 VC9 taken from here
PHP 5.3.3 from windows.php.net VC9
eaccelerator_ts.dll for 5.3.3 (VC9) taken from here (SVN425)

Running some scripts designed for php 5.3, using namespaces

So far no problems... and I hope it stays that way.

---
Edit: Ocasional crashes:

[Sun Nov 07 13:32:38 2010] [notice] EACCELERATOR(9108): PHP crashed on opline 22 of load() at H:\Library\DonReY\mod\application.php:156

And this is line 156:
require_once("{$this->CFG->compath}{$component_name}.php");

(a dynamic loading script ... The code checks if the file exists, and it does, or it won't reach that line)

[Sun Nov 07 13:32:38 2010] [crit] Parent: child process exited with status 3 -- Aborting.
Back to top
Smitty



Joined: 03 Jan 2008
Posts: 195

PostPosted: Tue 09 Nov '10 21:00    Post subject: Reply with quote

wavetrex:

Can you report your crashes to the eAccelerator website? I've seen some similar crashes using the PHP 5.3.3 module.
Back to top
Zach77



Joined: 26 Nov 2010
Posts: 1

PostPosted: Fri 26 Nov '10 14:23    Post subject: Reply with quote

Hi Millennium,

The new version you posted PHP 5.3.3 VC9 is very helpful to me. Very stable and flawless. Work perfectly with no bugs. Thank you. Smile



Shakeology | Shakeology Review | Shakeology Scam
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1