logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Other Software View previous topic :: View next topic
Reply to topic   Topic: Apache 2.4 encountered a problem with php5_module
Author
Hackathon



Joined: 12 Oct 2011
Posts: 2
Location: England

PostPosted: Sun 04 Mar '12 18:04    Post subject: Apache 2.4 encountered a problem with php5_module Reply with quote

I installed httpd-2.4.1-win64 VC9 and VC9 PHP 5.3.10 TS

and when I start Apache, I got this error:

Code:
C:\Windows\System32>net start Apache2.2
The Apache2.2 service is starting.
The Apache2.2 service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.



I also checked everything the paths and apache works perfectly without php when remove this line on http.conf

Code:


#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:\webserver\php\"
LoadModule php5_module "C:\webserver\php\php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 630

PostPosted: Sun 04 Mar '12 18:15    Post subject: Reply with quote

With Win64 it does not work.

Use a Apache 2.4 win32 VC9 or VC10 with the 5.4 handler php5apache2_4.dll from the download page.


Steffen
Back to top
Hackathon



Joined: 12 Oct 2011
Posts: 2
Location: England

PostPosted: Sun 04 Mar '12 18:40    Post subject: Reply with quote

Thanks... I'll try that

Edit: It works perfectly fine now.. Very Happy
Back to top
sakshi



Joined: 29 Apr 2012
Posts: 1
Location: patiala

PostPosted: Sun 29 Apr '12 18:31    Post subject: error occured Reply with quote

admin,i have the same problem, n i am using apache2.4 but still it shows error....why it happens?? Neutral Confused
Back to top


Reply to topic   Topic: Apache 2.4 encountered a problem with php5_module View previous topic :: View next topic
Post new topic   Forum Index -> Other Software