logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Third-party Modules View previous topic :: View next topic
Reply to topic   Topic: Apache 2.4.2 & mod_proxy_balancer bug
Author
manny



Joined: 23 Jun 2012
Posts: 3

PostPosted: Tue 03 Jul '12 17:55    Post subject: Apache 2.4.2 & mod_proxy_balancer bug Reply with quote

I've got this condition happening on my Apache 2.4.2 X64 installation:
https://issues.apache.org/bugzilla/show_bug.cgi?id=52402

So, there is a working patch but it has not yet been merged into module trunk. Does anyone have a patched mod_proxy_balancer DLL for this bug?

If not, I'll have to build it myself, which is fine. As I've never done that before on Windows, I could use some pointers to helpful threads within the forum. I'll be using Visual Studio 2010 - Visual C++.

Thanks!
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2264
Location: Sun Diego, USA

PostPosted: Wed 04 Jul '12 0:33    Post subject: Reply with quote

Edit: Remove 3 year old now dead link.

Last edited by glsmith on Tue 09 Jun '15 10:39; edited 1 time in total
Back to top
manny



Joined: 23 Jun 2012
Posts: 3

PostPosted: Thu 05 Jul '12 22:36    Post subject: Reply with quote

Thanks for building that module, glsmith. I really appreciate it a great deal.

While the patch seems to have worked for some, for whatever reason, it did not resolve the issue on my installation:

[proxy_balancer:emerg] [pid 6496:tid 620] (22)Invalid argument: AH01186: worker slotmem_grab failed

Commenting out all instances of BalancerMember stops the Apache crash (proving this is the culprit) but also disables the balancer module's intended purpose.

I may have to look for an alternative method of round-robin'ing my requests. I'm certain there are other mods that will handle that sort of routing.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7031
Location: Germany, Next to Hamburg

PostPosted: Fri 06 Jul '12 17:49    Post subject: Reply with quote

Can you please post your config? I want to reproduce that issue and might find some more info on my own system than.
Back to top
manny



Joined: 23 Jun 2012
Posts: 3

PostPosted: Fri 06 Jul '12 20:11    Post subject: Reply with quote

This is in my SSL configuration file and is embedded in the default SSL VirtualHost. It is the last configuration that appears in the VirtualHost. There are many additional configuration items before the Proxy settings that I've not included below.

Thanks!

Code:

<VirtualHost _default_:9000>

  ProxyTimeout 900
  SSLProxyEngine On
  ProxyPreserveHost On

  <Proxy balancer://my_cluster>
    BalancerMember https://paz:9000 route=nA
    BalancerMember https://baz:9000 route=nB
    ProxySet lbmethod=byrequests stickysession=FOO_STICKY nofailover=Off
  </Proxy>

  ProxyPass /foo/   balancer://my_cluster/foo/
  Header add Set-Cookie "FOO_STICKY=s.%{BALANCER_WORKER_ROUTE}e;path=/;secure" env=BALANCER_ROUTE_CHANGED

</VirtualHost>
Back to top


Reply to topic   Topic: Apache 2.4.2 & mod_proxy_balancer bug View previous topic :: View next topic
Post new topic   Forum Index -> Third-party Modules