logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: PHP 5.4.14 available (x86 & x64)
Author
Jan-E



Joined: 09 Mar 2012
Posts: 990
Location: Amsterdam, NL, EU

PostPosted: Thu 11 Apr '13 8:13    Post subject: PHP 5.4.14 available (x86 & x64) Reply with quote

Official builds:
http://windows.php.net/download/

My builds:
-compiled: Visual C++ 2008 (VC9)
-lots of extensions
-x86 including php_opcache.dll (was ZendOptimizerPlus)
-x86 including php_apcu.dll (APC user cache)

http://dl.dropbox.com/u/8954372/php-5.4.14-Win32-VC9-x64.zip
http://dl.dropbox.com/u/8954372/php-5.4.14-nts-Win32-VC9-x64.zip
http://dl.dropbox.com/u/8954372/php-5.4.14-Win32-VC9-x86.zip
http://dl.dropbox.com/u/8954372/php-5.4.14-nts-Win32-VC9-x86.zip

See the phpinfo.htm in the zip-files for information on the versions of some (but not all) of the extensions.

Be sure to use zend_extension=/...full path.../opcache.dll for the opcache. More info:
https://github.com/zend-dev/ZendOptimizerPlus
Back to top
rudhy



Joined: 21 Jan 2006
Posts: 6

PostPosted: Thu 11 Apr '13 9:51    Post subject: Reply with quote

Thank you for sharing.

Could you compile it with vc10 or vc11 ?

Regards,
Back to top
wm003



Joined: 24 Mar 2006
Posts: 88

PostPosted: Mon 15 Apr '13 16:47    Post subject: Reply with quote

Thanks Jan. I just recognized, php_curl.dll is broken (at least in the x86-nts, i just tested). php says, it cannot find the module (althought there is one available in your build)
When using the php_curl.dll from 5.4.12 nts-x86 it works.

[EDIT] checked with dependency walker: your php_curl.dll build depends on normaliz.dll which cannot be found. I am using it on Win XP and Win Server 2003. Not sure, if it will work on win7/2008

at least php_curl from 5.4.12 does not depend on normaliz.dll, thus that older version is working

[EDIT2]

The x64 Versions work, because normaliz.dll is found on win2008
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 990
Location: Amsterdam, NL, EU

PostPosted: Tue 16 Apr '13 13:37    Post subject: Reply with quote

The x86 version also worked on Win7/Win2k8. My libcurl.lib was compiled with USE_IDN=yes, which added IDN support and the dependency on normalized.dll:

http://en.wikipedia.org/wiki/Internationalized_domain_name

I now followed php.net's defaults: no IDN support in libcurl. The x86 zip's are already online and the x64 zip's will follow shortly.

BTW: I asked the PHP developers if it is not about time to enable IDN in PHP 5.5, now that XP support is dropped in that version.

Edit: running the dependency walker was not needed. The normal PHP build process already does that and creates a snapshot.txt that is in the zip's.
Back to top
Cy4n1d3



Joined: 22 Apr 2013
Posts: 17

PostPosted: Mon 22 Apr '13 15:04    Post subject: Reply with quote

Just wanted to drop by and thank you for your builds.
I'm using them in conjunction with the current 2.4.4 x64 Apache build from Steffen and they work great on Win 2008 R2.
Notably faster than the VC6 legacy builds I had to use with the old 2.2 apache...

Thanks alot!
Back to top
Brisingr Aerowing



Joined: 25 Jan 2013
Posts: 10

PostPosted: Thu 02 May '13 15:13    Post subject: Gettext Extension Reply with quote

Where did you get the version of Gettext you used to compile the php_gettext extension?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 990
Location: Amsterdam, NL, EU

PostPosted: Thu 02 May '13 16:19    Post subject: Reply with quote

The only thing you need for that is libintl_a.lib and the include files of libintl. For x86 you can find them here:
http://windows.php.net/downloads/php-sdk/

I do not remember where I got the x64 libintl_a.lib back in 2009. Maybe included in other packages like enchant or something like that.

Many libraries are currently available for compiling at https://github.com/winlibs

You might try your luck with the vcproj file at https://github.com/winlibs/gettext/blob/master/MSVC9/libintl_static/libintl_static.vcproj

Quote: OutputFile="Release\libintl_a.lib"
Back to top


Reply to topic   Topic: PHP 5.4.14 available (x86 & x64) View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads