logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



php5apache2_4.dll in PHP5.5 incompatible with Apache2.4

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
TAB



Joined: 30 Mar 2013
Posts: 4
Location: Haiti,Port-au-Prince

PostPosted: Thu 04 Jul '13 18:37    Post subject: php5apache2_4.dll in PHP5.5 incompatible with Apache2.4 Reply with quote

Running Apache2.4.4.0 with
https://dl.dropboxusercontent.com/u/8954372/php-5.5.0-Win32-VC11-x86
gives an error:
'Cannot load c:/php/php5apache2_4.dll into server: The specified procedure could not be found'
even though file c:/php/php5apache2_4.dll exists.
See also
http://www.apachelounge.com/viewtopic.php?t=5229
Back to top
GiGaByTe



Joined: 01 Aug 2013
Posts: 3
Location: Ukraine,Shytomur

PostPosted: Fri 02 Aug '13 16:20    Post subject: php5.5 problems Reply with quote

Problem that occurs is that the plugin is compiled in VC9 or VC10, and PHP 5.5 is not compatible with this version, since it was compiled in the VC11, the solution is to recompile the module php5apache2_4 in Visual studio 2012 express, the source code of the module must be present in the source code php!
Back to top
jrbbldr



Joined: 21 Nov 2013
Posts: 5

PostPosted: Thu 21 Nov '13 21:59    Post subject: Reply with quote

I too am experiencing the same problem as described in the original posting.

And since the symptoms are the same - Yes, it could very likely be a VC version issue.

Especially since I see "VC11" included in the downloaded filenames of:
httpd-2.4.6-win32-VC11.zip
php-5.5.6-nts-Win32-VC11-x86.zip

Does anyone have a version of php5apache2_4.dll that is compiled in VC11? (Maybe posted somewhere on the web for downloads?)

I have not yet found it anywhere and have no idea how to go about doing my own new compilation.

Since this seems that this is now a common problem with a good number of people, it would be good if it could be made available like the VC9 & VC10 versions are.

Thanks
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 597

PostPosted: Thu 21 Nov '13 22:25    Post subject: Reply with quote

You need to use the TS version of php 5.5.x, it has php5apache2_4.dll included for running as module with php5apache2_4.dll.


ps,
For mod_fcgid you need the nts version.
Back to top
jrbbldr



Joined: 21 Nov 2013
Posts: 5

PostPosted: Thu 21 Nov '13 22:51    Post subject: Reply with quote

Thank you for your reply.

What is the TS version of php 5.5.x ?

If it means "Thread Safe" that is what I thought I did download.

I got it under the category:
PHP 5.5 (5.5.6)
VC11 x86 Thread Safe (2013-Nov-13 20:57:44) on: http://windows.php.net/download/

And then, since the php5apache2_4.dll was not included within it, I got it from the ApacheLounge.com site.
But it was not compiled with VC11 and therefore not compatible.

Did I miss something?

Thanks,
jrbbldr
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 597

PostPosted: Fri 22 Nov '13 0:22    Post subject: Reply with quote

Just checked it:

The php5apache2_4.dll is in VC11 x86 Thread Safe (2013-Nov-13 20:57:44)
Back to top
jrbbldr



Joined: 21 Nov 2013
Posts: 5

PostPosted: Fri 22 Nov '13 2:14    Post subject: Reply with quote

Thank you for checking.

The PHP that I downloaded was:
php-5.5.6-nts-Win32-VC11-x86.zip

The filename implies that it is PHP 5.5.6 (32-bit version)

Based on the folders resulting from the Unzip of file: php5apache2_4.dll-php-5.4-win32.zip
It appears to contain DLL's to support versions for
PHP 5.4.0 Through PHP 5.4.9

And the Zip also contains a file named: -- For PHP 5.4 TS Apache 2.4 Win32 - VC9 or VC10 --

Within which it says:
Quote:
The module works with Apache 2.4 Win32 VC9 or VC10, see ReadMe.txt


Does this DLL Zip file also support PHP 5.5.6 ?

If it does then, maybe the symptoms that I am encountering (same as in this Thread's original posting) are not due to VC version, but it seemed as though it was.

Any other suggestions?

Thanks,
jrbbldr
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2747
Location: Hilversum, NL, EU

PostPosted: Fri 22 Nov '13 11:40    Post subject: Reply with quote

Do not understand you.

Just download:

http://windows.php.net/downloads/releases/php-5.5.6-Win32-VC11-x86.zip

or

http://windows.php.net/downloads/releases/php-5.5.6-Win32-VC11-x64.zip

The php5apache2_4.dll is included in both downloads.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1