logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Other Software View previous topic :: View next topic
Reply to topic   Topic: localhost:8080
Author
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Thu 25 Jul '13 16:10    Post subject: localhost:8080 Reply with quote

In http://localhost :8080/ I see fallowing php codes printed!

I am using 2.4.6 www.apachelounge.com/download/VC11/
And my PHP is 5.5.1 from http://windows.php.net/download/ VC11 x64 Non Thread Safe (2013-Jul-18 22:48:53)

This is what I see in http://localhost :8080/

execute($sql); $viewed_videos = $rs->getrows(); $viewed_total = count($viewed_videos); $sql = "SELECT VID, title, duration, addtime, thumb, thumbs, viewnumber, rate, type, hd FROM video" .$sql_add. " ORDER BY addtime DESC LIMIT " .$config['recent_per_page']; $rs = $conn->execute($sql); $recent_videos = $rs->getrows(); $smarty->assign('errors',$errors); $smarty->assign('messages',$messages); $smarty->assign('menu', 'home'); $smarty->assign('index', true); $smarty->assign('viewed_total', $viewed_total); $smarty->assign('viewed_videos', $viewed_videos); $smarty->assign('recent_videos', $recent_videos); $smarty->assign('self_title', $seo['index_title']); $smarty->assign('self_description', $seo['index_desc']); $smarty->assign('self_keywords', $seo['index_keywords']); $smarty->display('header.tpl'); $smarty->display('errors.tpl'); $smarty->display('messages.tpl'); $smarty->display('index.tpl'); $smarty->display('footer.tpl'); $smarty->gzip_encode(); ?>

I have the fallowing in VirtualHosts;

<VirtualHost 127.0.0.1:8080>
ServerAdmin myavsforums@yahoo.com
DocumentRoot "C:/Apache24/htdocs"
ServerName localhost
ServerAlias localhost
<Directory "C:\Apache24\htdocs">
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost 127.0.0.1:8080>
ServerAdmin myavsforums@yahoo.com
DocumentRoot "C:/Apache24/htdocs"
ServerName my.local
ServerAlias www.my.local
<Directory "C:\Apache24\htdocs">
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

How can I get rid of :8080 requirement?

Please correct me on \ and /

Can somebody correct me on this please?

You can request my php.ini and httpd.conf files for you by email to myavsforums@yahoo.com

Thank you so much
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 625

PostPosted: Thu 25 Jul '13 16:25    Post subject: Reply with quote

You posted in the wrong forum. We moved it.

Your subject is not meaningful, please change it !!.

Do not expect that someone is contacting you for you httpd.conf and php.ini.
It is common to post it in a past bin, see forum rules.

As stated in the registration mail, please consult the forum rules (see left top menu) before you post.


Last edited by admin on Sat 27 Jul '13 15:45; edited 1 time in total
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6966
Location: Germany, Next to Hamburg

PostPosted: Thu 25 Jul '13 17:02    Post subject: Reply with quote

For PHP see Basic PHP Troubleshooting --> http://www.apachelounge.com/viewtopic.php?t=2395

if you don't want to see the 8080 change any 8080 in your apache config to 80
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Fri 26 Jul '13 22:01    Post subject: Re: Reply with quote

the reason to use port 8080 is because i have IIS 7

is this correct?
DocumentRoot "C:/Apache24/htdocs"
or
DocumentRoot "C:\Apache24\htdocs"
which one?

also

<Directory "C:\Apache24\htdocs">
or
<Directory "C:/Apache24/htdocs">
which one?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6966
Location: Germany, Next to Hamburg

PostPosted: Sat 27 Jul '13 12:52    Post subject: Re: Reply with quote

Tadeh wrote:
the reason to use port 8080 is because i have IIS 7

If you have several IP adresses you can bind IIS to one of them on port 80 and apache to the other IP on port 80. Otherwise you have to live the the 8080.

Tadeh wrote:

is this correct?
DocumentRoot "C:/Apache24/htdocs"
or
DocumentRoot "C:\Apache24\htdocs"
which one?

also

<Directory "C:\Apache24\htdocs">
or
<Directory "C:/Apache24/htdocs">
which one?


Both will work Wink Just stick to one style.
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sat 27 Jul '13 16:45    Post subject: Re: Reply with quote

I tried 192.168.1.100:80
and
192.168.1.200:80 before

but in command prompt typing
C:\Apache24\bin\httpd.exe then enter
it says only one ip/port is allowed!
strange

i also tried lan 1 and lan 2 of modem to network adaptor 1 and 2 of my PC (2 connections from modem to pc)
then i merged them into one connection and i built c class IP model
in Internet Protocol v4 advanced settings I modified and i added 192.168.1.200 to 192.168.1.100

Did you mean this?


----------
Mod note: merged second post

----------



If you look at Basic Examples here
http://httpd.apache.org/docs/2.2/mod/mod_proxy.html
There is a ReverseProxy
and
There is a ForwardProxy

I have IIS/Apache port 80 conflict and port 8080 challenge!
I just can't get rid of :8080 to resolve as .com/ or .com:80/

I have tried my best to solve this way...
Please correct me as I am not 100% sure...

Code:
<VirtualHost 127.0.0.1:8080>
ServerAdmin email@example.com
DocumentRoot "C:/Apache24/htdocs"
ServerName example.com
ServerAlias www.example.com
<Location 127.0.0.1:8080/example2/>
ProxyPass / http://127.0.0.1/
ProxyPassReverse / http://127.0.0.1/
</Location>
ProxyRequests On
ProxyVia On
<Proxy *>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Proxy>
ErrorLog "C:/Apache24/logs/example.com-error.log"
CustomLog "C:/Apache24/logs/example.com-access.log" common
<Directory "C:/Apache24/htdocs">
Options FollowSymLinks Includes ExecCGI MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sun 28 Jul '13 21:26    Post subject: Re: Reply with quote

Changing 8080 to 80 only works if i don't have IIS
I did what you said. It says;
The requested operation has failed.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2863
Location: Hilversum, NL, EU

PostPosted: Sun 28 Jul '13 22:01    Post subject: Reply with quote

I following your 8080 posts (some we splitted/merged/removed).

Still do not know what exactly your issue is.

You want to run IIS and Apache ?

If yes, different content IIS and Apache ?.

And both without adding 8080 to the url ?

Please describe you issue or what you want to achieve more clearly, so we can help. And not dumping too much config snippets.

Steffen
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sun 28 Jul '13 22:24    Post subject: Re: Reply with quote

yes yes
i have windows server 2008 enterprise x64 R2 edition. ok?
i had IIS from years ago hosting multiple websites on it.
Now i have got a php/apache/mysql video streaming website script i installed on apache 2.4.4

yes different content websites on iis and apache as you stated
by the way; php code printed instead of execution is fixed now by editing
C:\Apache24\conf\extra\httpd-userdir.conf

the problem is that IIS already occupied port 80 and i can not use it for apache because it is not available. so i am using port 8080

Can you please correct this so that this works please? Smile the goal should be example.com do not need :8080 as example.com:8080 to work and work as example.com

Thank you

Code:
<VirtualHost 127.0.0.1:8080>
ServerAdmin email@example.com
DocumentRoot "C:/Apache24/htdocs"
ServerName example.com
ServerAlias www.example.com
<Location 127.0.0.1:8080/example2/>
ProxyPass / http://127.0.0.1/
ProxyPassReverse / http://127.0.0.1/
</Location>
ProxyRequests On
ProxyVia On
<Proxy *>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Proxy>
ErrorLog "C:/Apache24/logs/example.com-error.log"
CustomLog "C:/Apache24/logs/example.com-access.log" common
<Directory "C:/Apache24/htdocs">
Options FollowSymLinks Includes ExecCGI MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2863
Location: Hilversum, NL, EU

PostPosted: Sun 28 Jul '13 22:43    Post subject: Reply with quote

Still not clear enough for me.

So you want only the video streaming script called without 8080 ?

So you want all called without 8080 ?

Why not run Apache on 80 and IIS on 8080 ?
And ProxyPass to IIS.

When you want to keep IIS on port 80, you can proxy to Apache with ARR in IIS.

IIS 80 <===> Apache 8080



You should add before the ProxyPass:

ProxyPreserveHost On

Steffen
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sun 28 Jul '13 22:51    Post subject: Re: Reply with quote

Hello and thank you for your quick respond

You said ProxyPreserveHost On
Is this for IIS 80 Apache 8080 or vice-verse?

I want to keep IIS on port 80, and proxy to Apache with ARR in IIS

Please guide me on this.

Thank you sooo much
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2863
Location: Hilversum, NL, EU

PostPosted: Sun 28 Jul '13 23:04    Post subject: Reply with quote

So you want:

IIS 80 <===> Apache 8080 (or whatever) with the video script.

First remove all the poxy stuff from your httpd.conf.

Then follow: http://sahelp.sharepointforall.com/FAQ/bconfigure_IIS.html

Please stay now on the subject, other issues open a new thread Smile

Steffen
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sun 28 Jul '13 23:12    Post subject: Re: Reply with quote

with this both iis and apache function on port 80?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2863
Location: Hilversum, NL, EU

PostPosted: Sun 28 Jul '13 23:18    Post subject: Reply with quote

Yep IIS has to go to Apache when the video script is called.

At Apache Lounge we runned as test that the download only where served by IIS and the rest (like this forum) by Apache:

IIS 80 (download folder only) <==Rest=> Apache 8080.

So www.apachelounge.com/download by IIS
and www.apachelounge.com goes through IIS to Apache.

Steffen
Back to top
Tadeh



Joined: 25 Jul 2013
Posts: 11
Location: United States, Los Angeles

PostPosted: Sun 28 Jul '13 23:22    Post subject: Re: Reply with quote

so still in Apache I have to keep Listen 8080 and
ServerName 127.0.0.1:8080
ServerName 192.168.1.100:8080
ServerName example.com:8080

am i correct?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2863
Location: Hilversum, NL, EU

PostPosted: Sun 28 Jul '13 23:32    Post subject: Reply with quote

I believe you do not have to use a Virtual host in Apache for you video script.

Just and no vhost:

Listen 8080 or whatever
Servername example.com or what ever name.

Please read it at http://sahelp.sharepointforall.com/FAQ/bconfigure_IIS.html

Specific IIS questions you should ask in an IIS forum.


Steffen
Back to top


Reply to topic   Topic: localhost:8080 View previous topic :: View next topic
Post new topic   Forum Index -> Other Software