Apache Lounge



Forum Index Downloads Search Register Log in  RSS Apache Lounge

Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.



A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.

Apache Service will not start when using SSL

Post new topic   Reply to topic    Apache Forum Index -> Apache

View previous topic :: View next topic  
Author Message

Joined: 25 Apr 2017
Posts: 2
Location: US PENN

PostPosted: Tue 25 Apr '17 20:01    Post subject: Apache Service will not start when using SSL Reply with quote

Hello all,
I'm trying to set up SSL on Apache 2.4.25(32bit) on Windows Server 2012 64bit.

When I try to start Apache as a service through the GUI I get the error message:

“Windows could not start the Apache2.4 on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to the servic-specific error code 1.”

There are no errors in the Apache log files.

Before I began to configure ssl, the service worked correctly with no issues.

When I review the windows event viewer there is a message:

The Apache service named reported the following error: >>> SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?).

I looked this up and the solution was to uncomment the line in the httpd.conf file:

LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

But even with that modification, I still get the same error.

I have verified that the mod_socache_shmcb.so and mod_ssl.so are located in the correct directory.

Has anyone else run into this?

Thanks in advance for any suggestions.

Back to top

Joined: 15 Apr 2012
Posts: 181
Location: Denver, CO USA

PostPosted: Tue 25 Apr '17 20:10    Post subject: Reply with quote

In your first line of your issue, you state that you are running Apache 2.4.x (32-bit) on Windows Server 2012 (64-bit).

It is a good idea to be running the 64-bit version of Apache if your OS is 64-+bit.

You may want to start there. Also, go through your SSL Conf file and check to see if OCSP stapling is on. If it is, you may want to comment it out.

Try those and see if your issue is resolved.
Back to top

Joined: 16 Oct 2007
Posts: 2169
Location: Sun Diego, USA

PostPosted: Tue 25 Apr '17 20:39    Post subject: Reply with quote

Did you restart the server after uncommenting the LoadModule line for mod_socache_shmcb?
Back to top

Joined: 25 Apr 2017
Posts: 2
Location: US PENN

PostPosted: Tue 25 Apr '17 21:32    Post subject: It's Alive! Reply with quote

So first, thanks to all the suggestions. Much appreciated!

I did reinstall the 64bit version but still had the same problem but it got me to thinkin...

Next, I decided to take a step back and attempt to start it from the command line and forget running it as a service first.

Luckily by doing that I received some useful errors stating that "The cert does not include an ID that matches the server name..." the issue was that the servername in the ssl conf file included the "www." so yeah that could be a problem. Once that was corrected life was once good again and I could install it as a service and run it with no issues!

Once again thanks to all with the help!

All the best,

Back to top

Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1