logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: Apache Build Lacking iconv/*.so Files
Author
esayitch



Joined: 12 Nov 2013
Posts: 3
Location: Israel, Haifa

PostPosted: Tue 12 Nov '13 14:53    Post subject: Apache Build Lacking iconv/*.so Files Reply with quote

Hello,

I'm currently building Apache using Visual Studio 12 (VC110). After finishing, I downloaded the binaries in Apache Lounge to compare them to mine; in terms of files present, there are only the following differences:

1) From bin/iconv: All .so files are missing in my build.
2) The following modules are missing from Modules: A) mod_lua, mod_session_crypto.

For reference, my mod_xml2enc module was compiled using libxml2 which itself was compiled without iconv and without zlib.

My question is: What do I need to do to build all of the missing .so files in bin/iconv (in the source folder, they are built in srclib/apr-iconv/Release/iconv)?

Do I need to have iconv? If yes, do I need to compile libxml2 with iconv?

Thank you for your time and knowledge,
Suhail
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2268
Location: Sun Diego, USA

PostPosted: Tue 12 Nov '13 19:29    Post subject: Reply with quote

Iconv:

Do you need it? Maybe
Do you need to compile libxml2 with iconv? No.
On VC 2012 & I guess 2013 you need to make an adjustment to the makefile or the build fails. The patch below should fix you up.

Code:
Index: srclib/apr-iconv/build/modules.mk.win
===================================================================
--- srclib/apr-iconv/build/modules.mk.win   (revision 1489655)
+++ srclib/apr-iconv/build/modules.mk.win   (working copy)
@@ -214,10 +214,10 @@
 $(MODRES).pch:
         $(SILENT)echo #define ICONV_INTERNAL > $*.c
         $(SILENT)echo #include "iconv.h" >> $*.c
-   $(SILENT)cl $(ALL_CFLAGS) /Fo$*.obj /Yciconv.h /c $*.c
+   $(SILENT)cl $(ALL_CFLAGS) /Fo$*.obj /c $*.c
 
 .c{$(OUTPUT_DIR)}.so:
-   $(SILENT)cl $(ALL_CFLAGS) /Fo$*.obj /Yuiconv.h /c $<
+   $(SILENT)cl $(ALL_CFLAGS) /Fo$*.obj /c $<
    $(SILENT)link $(ALL_LDFLAGS) $*.obj $(API_LIBS) /out:$@ \
       /base:@"..\build\BaseAddr.ref",$(@F)
    $(SILENT)if exist $@.manifest \


mod_lua:
Needs to have LUA built and sitting in srclib/lua

mod_session_crypto:
You need to set APR_HAVE_CRYPTO to 1 in srclib/apr-util/include/apu.h
You need to check the box next to it's name in the dependencies of BuildBin (right click on BuildBin -> Project Dependencies)
Back to top
esayitch



Joined: 12 Nov 2013
Posts: 3
Location: Israel, Haifa

PostPosted: Wed 13 Nov '13 10:54    Post subject: Reply with quote

Hi Again,

Thank you a lot for the assistance, the iconv issue was resolved after the patch you posted Smile.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 680

PostPosted: Wed 13 Nov '13 11:24    Post subject: Reply with quote

Next time, please search first the forum. For example about iconv, see www.apachelounge.com/viewtopic.php?t=5394
Back to top


Reply to topic   Topic: Apache Build Lacking iconv/*.so Files View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads