logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Configure apache 2.4 for php 5.5.6 php5apache2_4.dll

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Tue 10 Dec '13 15:55    Post subject: Configure apache 2.4 for php 5.5.6 php5apache2_4.dll Reply with quote

I am unable to setup PHP with apache.

---------------------------
Warning
---------------------------
PHP Startup: Invalid library (maybe not a PHP library) 'php5apache2_4.dll'
---------------------------
OK
---------------------------
The above is the error i am getting when i give php -i.




I have added
1)extension=php5apache2_4.dll,
2) extension_dir = "D:/Softwares/php/ext"
in php.ini file

LoadModule php5_module "D:/Softwares/php/php5apache2_4.dll" in httpd.conf
<Directory "D:/Softwares/php">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

PHPIniDir "D:/Softwares/php"

AddType application/x-httpd-php .php
AddHandler application/x-httpd-php .php
all above in httpd.conf

Please help...
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Tue 10 Dec '13 18:59    Post subject: Reply with quote

You set up is almost alright. But don't load that dll in php.ini. When you delete that line in your php.ini php should run fine.
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Wed 11 Dec '13 9:55    Post subject: Reply with quote

Getting following error when i remove extension=php5apache2_4.dll from php.ini


httpd.exe: Syntax error on line 130 of C:/Program Files/Apache Software Foundati
on/Apache2.2/conf/httpd.conf: Cannot load D:/Softwares/php/php5apache2_4.dll int
o server: The specified procedure could not be found.

Thank you
Back to top
Mandrake



Joined: 11 Dec 2013
Posts: 3
Location: Denmark, Copenhagen

PostPosted: Wed 11 Dec '13 11:38    Post subject: Reply with quote

Looking at your path:
"C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf"
It seems you are using Apache v2.2 so you should use the php5apache2.dll module instead of php5apache2_4.dll because it is for Apache v2.4.

Regards.
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Wed 11 Dec '13 14:16    Post subject: Reply with quote

Ater replacing php5apache2.dll...when i start the server it is giving following error..same as above...


httpd.exe: Syntax error on line 130 of C:/Program Files/Apache Software Foundati
on/Apache2.2/conf/httpd.conf: Cannot load D:/Softwares/php/php5apache2.dll into
server: The specified procedure could not be found.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 11 Dec '13 15:05    Post subject: Reply with quote

PHP 5.5 does not support Apache 2.2
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Wed 11 Dec '13 15:37    Post subject: Reply with quote

which version of PHP i need to use for apache 2.2.
and also version of php5apache2.dll ???

Thank you
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Wed 11 Dec '13 20:10    Post subject: Reply with quote

Mandrake is partially correct but the proper dll for Apache 2.2 is php5apache2_2.dll

The bigger problem I'm seeing is that it looks like the Apache you are using is from the .msi installers at http://www.apache.org/dist/httpd/

If this is the case none of the PHP versions currently available will work with your Apache (as stated on the windows.php website) because the Apache's at apache.org are built with Visual C++ 6.0 and PHP versions 5.3 and up are built with either Visual C++ 2008 (VC9) or 2012 (VC11).
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Thu 12 Dec '13 7:54    Post subject: Reply with quote

This is the first time i am doing the PHP setup.please provide me the proper steps with versions and from where i can download..

Thank you
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 12 Dec '13 12:45    Post subject: Reply with quote

With new version Apache 2.4 and new PHP you can read http://www.apachelounge.com/viewtopic.php?t=2394

if you want to use an older version of PHP you can download it from http://windows.php.net/downloads/releases/archives/
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Thu 12 Dec '13 13:06    Post subject: Reply with quote

Unable to uninstall Apache2.2. I have used the following commands.

1) httpd -k uninstall -n Apache2.2
2) httpd -k uninstall -n "Apache2.2"
3) httpd -k uninstall



c:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd -k uninstall -n
Apache2.2
[Thu Dec 12 16:30:20 2013] [error] (OS 2)The system cannot find the file specifi
ed. : No installed service named "Apache2.2".

c:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd -k uninstall -n
"Apache2.2"
[Thu Dec 12 16:30:51 2013] [error] (OS 2)The system cannot find the file specifi
ed. : No installed service named "Apache2.2".

Thank You
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Thu 12 Dec '13 13:13    Post subject: Reply with quote

No installed service named "Apache2.2"

skip that step, the service is not there to uninstall.
Back to top
twiw.india@gmail.com



Joined: 10 Dec 2013
Posts: 7
Location: pune

PostPosted: Thu 12 Dec '13 13:19    Post subject: Reply with quote

But Apache2.2 is already installed in my system.If i install new version won't it be conflict?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Thu 12 Dec '13 20:44    Post subject: Reply with quote

Apache may be installed, but there is no Windows Service installed named Apache2.2, it may have some other name however and I can't guess the name if it is there.

You installed Apache with an installer right? How about uninstalling it from Add/Remove Programs in XP/2003 or Programs and Features in WinVista/7/8/2008/2012, which can be found in the control panel.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1