logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: PHP 5.5.7, 5.4.23, 5.3.28 (x86/x64) available
Author
Jan-E



Joined: 09 Mar 2012
Posts: 1034
Location: Amsterdam, NL, EU

PostPosted: Fri 13 Dec '13 4:20    Post subject: PHP 5.5.7, 5.4.23, 5.3.28 (x86/x64) available Reply with quote

PHP 5.5.7, 5.4.23, 5.3.28 have been released. From the announcement of PHP 5.3.28:
Quote:
The PHP development team announces the immediate availability of PHP 5.3.28. This release fixes two security issues in OpenSSL module in PHP 5.3 - CVE-2013-4073 and CVE-2013-6420. All PHP 5.3 users are encouraged to upgrade to PHP 5.3.28 or latest versions of PHP 5.4 or PHP 5.5.

Release notes:
http://www.php.net/ChangeLog-5.php#5.5.7
http://www.php.net/ChangeLog-5.php#5.4.23
http://www.php.net/ChangeLog-5.php#5.3.28

Downloads of the Windows versions:
http://windows.php.net/download/

Many extensions are also available on php.net:
http://windows.php.net/downloads/pecl/releases/

My builds:
http://phpdev.toolsforresearch.com/php-5.5.7-nts-Win32-VC11-x86.zip
http://phpdev.toolsforresearch.com/php-5.5.7-Win32-VC11-x86.zip
http://phpdev.toolsforresearch.com/php-5.5.7-nts-Win32-VC11-x64.zip
http://phpdev.toolsforresearch.com/php-5.5.7-Win32-VC11-x64.zip

http://phpdev.toolsforresearch.com/php-5.4.23-nts-Win32-VC9-x86.zip
http://phpdev.toolsforresearch.com/php-5.4.23-Win32-VC9-x86.zip
http://phpdev.toolsforresearch.com/php-5.4.23-nts-Win32-VC9-x64.zip
http://phpdev.toolsforresearch.com/php-5.4.23-Win32-VC9-x64.zip

http://phpdev.toolsforresearch.com/php-5.3.28-nts-Win32-VC9-x86.zip
http://phpdev.toolsforresearch.com/php-5.3.28-Win32-VC9-x86.zip
http://phpdev.toolsforresearch.com/php-5.3.28-nts-Win32-VC9-x64.zip
http://phpdev.toolsforresearch.com/php-5.3.28-Win32-VC9-x64.zip

If you have got the choice, use the binaries from php.net because they are built with PGO and are faster.

The extensions in my 5.5.x builds can be mixed with the php.net binaries.

My 5.4.x and 5.3.x builds use OpenSSL 1.0.1e, while php.net uses OpenSSL 0.9.8y for 5.3 & 5.4. Be careful with mixing my extensions with the official 5.3/5.4 binaries.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1034
Location: Amsterdam, NL, EU

PostPosted: Sat 14 Dec '13 3:24    Post subject: Reply with quote

I forgot to mention that my builds now contain pecl-http version 2.x. Required for the 2.x branch is that you load php_propro and php_raphf before loading php_http:

extension=php_propro.dll
extension=php_raphf.dll
extension=php_http.dll

More info: http://pecl.php.net/package/pecl_http
Back to top
Johnny Cache



Joined: 13 Dec 2013
Posts: 3
Location: Instruments, TX

PostPosted: Sat 14 Dec '13 19:39    Post subject: Reply with quote

Hi, Jan-E! First, I'd like to thank you making all these different versions of PHP available to those of us without access to a proper compiler. You've certainly made my job a lot easier!

Sorry to say this, but I need to report a minor problem: when I try to use your 5.4.23 build (php-5.4.23-Win32-VC9-x64.zip) on my 64bit Windows 2003 server, I get: "The procedure entry point K32QueryWorkingSet could not be located in the dynamic link library KERNEL32.dll." and the OCI8 modules don't load (it says they can't be found).

Your 5.4.22 build works fine on the same machine. Mayhap you compiled with the wrong libraries this time?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1034
Location: Amsterdam, NL, EU

PostPosted: Sun 15 Dec '13 13:49    Post subject: Reply with quote

I know that there have been a lot of changes in the OCI8 extension sources. If the same happens with the official php.net DLL's, you should file a bug report (with the chance to get the answer that win2003 is not supported anymore in this extension).

The official php.net DLL's are here:
http://pecl.php.net/package/oci8/2.0.6/windows
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1034
Location: Amsterdam, NL, EU

PostPosted: Sun 15 Dec '13 14:00    Post subject: Reply with quote

I now see you are using the 64-bit 5.4 version which is not officially available. Could you try 32-bit PHP with the official php.net DLL's?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1034
Location: Amsterdam, NL, EU

PostPosted: Sun 15 Dec '13 18:38    Post subject: Reply with quote

Try removing psapi.dll from the PHP-dir. psapi.dll is Windows version specific and was not there in my 5.4.22 builds.
Back to top
Johnny Cache



Joined: 13 Dec 2013
Posts: 3
Location: Instruments, TX

PostPosted: Mon 16 Dec '13 16:45    Post subject: Reply with quote

Thanks, Jan-E! Removing psapi.dll did the trick. You da man! Very Happy
Back to top


Reply to topic   Topic: PHP 5.5.7, 5.4.23, 5.3.28 (x86/x64) available View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads