logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: ERROR WITH APACHE 2.X
Author
jbdj



Joined: 07 Aug 2006
Posts: 3

PostPosted: Mon 07 Aug '06 17:39    Post subject: ERROR WITH APACHE 2.X Reply with quote

Steffen,

I thought that I was resolved that problem with php5 and apache2 when I restarted my machine.

But the problem is when I go to start->all programs->apache http server 2.2.3->control apache server (there are 4 options (monitor apache servers, restart, start and stop)), when a choose start appears 2 errors

Sometimes the prompt window appear and disappear fast and the apache does not works

Sometimes (most frequently) appear the follow message:

"<OS 10048> Only one usage of each socket address <protocol/network address/port> is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs"

But the thing most interest is that if I go to start->all programs->apache http server 2.2.3->monitor apache servers, the apache works immediatly.

The problem is with the start option in start->all programs->apache http server 2.2.3->control apache server->start

Do you have any ideia what can is happening?

JBDJ
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Mon 07 Aug '06 17:45    Post subject: Reply with quote

Quote:
<OS 10048> Only one usage of each socket address <protocol/network address/port> is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs


Another application/service is using Port 80. Do you have IIS running? If you install CurrPorts ( http://www.nirsoft.net/utils/cports.html ), it show if another application is using Port 80.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 3045
Location: Hilversum, NL, EU

PostPosted: Mon 07 Aug '06 17:48    Post subject: Reply with quote

The <OS 10048> you get probably that Apache is not stopped yet completely and you try to start it again.

I am using only ApacheMonitor.exe in the Apache/bin folder and do not see the issue.

Steffen
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Mon 07 Aug '06 17:57    Post subject: Reply with quote

Also, Apache Monitor is exactly that - a monitor. You should notice a feather with a circle.

If there's a red square in the circle - that means that Apache IS NOT running.

If theres's a green triangle (like play) - that means that Apache IS running.

If you SINGLE LEFT CLICK on the icon, then a menu is displayed that presents the options to Start, Stop, and Restart. That START option is the same START that you have in Start |All Programs | Apache HTTPS Server 2.2.3 | Control Apache Server | Start
Back to top
jbdj



Joined: 07 Aug 2006
Posts: 3

PostPosted: Mon 07 Aug '06 21:32    Post subject: Reply with quote

Ok, I will use only ApacheMonitor.exe, like Steffen do.

But I have other problem. Every time that I turn on de computer the apache works automatically. I would like that it just work when I want through the ApacheMonitor.exe.

I think that can be some configuration in the http.conf, but I don't know where.

JBDJ
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Mon 07 Aug '06 23:30    Post subject: Reply with quote

Actually, that's a Windows Services issue and not a Apache config issue.

Do the following to setup for on-demand service:

1. START | RUN
2. Type in services.msc, hit Enter or click OK
3. Locate Apache2 service and double-click (or right-click for Properties)
4. Find the caption Startup type: (in the middle of the dialog box), use the pull-down and select Manual
5. Click OK

That will take of it for you.
Back to top


Reply to topic   Topic: ERROR WITH APACHE 2.X View previous topic :: View next topic
Post new topic   Forum Index -> Apache