logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache Error loading phpMyAdmin configuration file

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
Wild Goose



Joined: 31 Oct 2015
Posts: 2

PostPosted: Sat 31 Oct '15 19:58    Post subject: Apache Error loading phpMyAdmin configuration file Reply with quote

Hi, I am running opensuse 13.2 with apache, and have just installed mysql server and phpMyAdmin.

when I try to start httpd2, I get this error message:

Code:
AH00526: Syntax error on line 22 of /etc/apache2/conf.d/phpMyAdmin.conf:
Invalid command '<IfVersion', perhaps misspelled or defined by a module not included in the server configuration


That section of phpMyAdmin.conf file looks like this:

Code:
<Directory /srv/www/htdocs/phpMyAdmin/libraries>
  <IfVersion >= 2.4>
    Require all denied
  </IfVersion>
  <IfVersion < 2.4>
    Order allow,deny
    Deny from all
  </IfVersion>
</Directory>


Line 22 is where it states <IfVersion < 2.4>

I was wondering if it was a simple syntax problem, or something else?

Thanks
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Sat 31 Oct '15 20:17    Post subject: Reply with quote

Did you have mod_version module enabled in httpd.conf ?
Back to top
Wild Goose



Joined: 31 Oct 2015
Posts: 2

PostPosted: Sun 01 Nov '15 8:37    Post subject: Solved! Reply with quote

Thanks, the version module was listed in /etc/sysconfig/apache2 but did not show up as being loaded in /etc/apache2/sysconfig.d/loadmodule.conf.

But it turned out I was using the wrong command to start apache.

I was using

Code:
#httpd2 -k start


which gave the version error, but when I tried

Code:
#rcapache2 start


it all worked fine.

It's been a while since I've used this stuff, so sorry for the rookie error.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1