logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



My NonFaulty Setup Apache 2.4.18 + PHP 5.6.16 + 7.0.1+MYSQL

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
dynmosaic



Joined: 15 Dec 2005
Posts: 10

PostPosted: Wed 30 Dec '15 5:20    Post subject: My NonFaulty Setup Apache 2.4.18 + PHP 5.6.16 + 7.0.1+MYSQL Reply with quote

Happy Holidays Everyone,

Just would like to share an experience with my initial Apache + PHP + MySQL setup, how that prevented me from installing Joomla 3.4.x or earlier versions. Then I provided a workaround to allow Joomla 3.4.x to install. In the end, I have some questions that I needed some answers.

First, I will share my original setup.

1. Apache 2.4.18 x64 VC14
2. PHP 7.0.1 x64 VC14 and PHP 5.6.16 x32 VC11 running in FastCGI mode
3. MySQL 5.7.10 x64

The above setup does work for wordpress 4.4, Joomla 3.5 beta 1 (both PHP 5 and PHP 7), however, it choked on Joomla 3.4.x or earlier.

A user from Joomla support site kindly helped me to realize very painfully that this setup won't work.

Second, I will share my current setup.

1. Apache 2.4.18 x64 VC 11
2. PHP 7.0.1 x64 VC 14, PHP 5.6.16 x32 VC11 running in FastCGI mode
3. MySQL 5.7.10 x64

This new setup works for everything, wordpress 4.4 (both PHP5 and PHP7), Joomla 3.4.x (PHP5 only, as PHP7 is not supported), Joomla 3.5 beta 1 (both PHP5 and PHP7).

Finally, my questions:

1. Why the first setup fails for Joomla 3.4.x?
2. Why the second setup works? There is a mixture of VC 11 and VC14 binaries, as there is no VC 11 build for PHP 7, nor is there a VC14 build for PHP 5.x.
3. For Apache 2.4.18 x64 VC11 build, is there a newer version 2.9 of the mod_security2 for VC 11? Also, is there a mod_evasive2 available for VC11 build?

Thanks,

Mosaic


Last edited by dynmosaic on Sat 02 Jan '16 0:13; edited 2 times in total
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Wed 30 Dec '15 10:50    Post subject: Reply with quote

Any errors in the Apache error.log and/or Windows Event Viewer? What is the issue with Joomla ?

No plans for now to make mod_evasive and mod_security 2.9 available for VC11 here. When I recall Apachehaus has a VC11 version of mod_evasive.
Back to top
dynmosaic



Joined: 15 Dec 2005
Posts: 10

PostPosted: Wed 30 Dec '15 15:12    Post subject: Reply with quote

Happy New Year, Steffan.

I was able to load mod_security2 version 2.8, forgot to copy the dll into the Apache binary directory, I was too fast to try to figure out the problem.

The problem with Joomla 3.4.x or earlier, during the installation, it has a step that it will try to backup or remove (depending on user's choice) the existing database tables (say if you had an old installation in the same database), it will simply stuck there - even if I made sure I had an empty database to start with. I tried the same with Joomla 3.5 beta 1, no problem at all under my initial setup or the second setup, I can use PHP5 or PHP7, no problem, as Joomla 3.5 beta 1 has support for PHP7.

There is no log to indicate any problems. Because my guess is, it's simply not doing anything, maybe it's chocked on trying to connect to the database, I would not know.

My old setup is still there. I can simply symlink to it and retest if you have any suggestions for me to try.

I would prefer for my initial setup to work.
Back to top
dynmosaic



Joined: 15 Dec 2005
Posts: 10

PostPosted: Sat 02 Jan '16 1:00    Post subject: Reply with quote

I located the mod_evasive2 (VC11) from Apachehause, and suddenly, Joomla 3.4.8 not working again. Then I realize, maybe something is wrong with my setup with mod_evasive2. I notice there is a dos-127.0.0.1 file in the log directory. So I removed the file, and also whitelisted 127.0.0.1, now Joomla 3.4.8 is installing fine, with my original setup. Did not know that dos-127.0.0.1 was created at some point, possibly while I am testing the module. Now, the question is, how come this file only impact the Joomla 3.4.8 installation, it did not impact 3.5 beta installation, neither did it impact the wordpress installation.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1