logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



OwnCloud and Apache

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
focusrite_sfoster



Joined: 18 Dec 2015
Posts: 3

PostPosted: Mon 04 Jan '16 17:33    Post subject: OwnCloud and Apache Reply with quote

Hi all!

First post here and I'm not too experienced with Apache.

I've set up OwnCloud on Debian Jessie running on Apache and everything works well however I'm trying to set it so that I can access owncloud via

https://my-owncloud.lan/ instead of https://my-owncloud.lan/owncloud/

I have been advised there are two ways to do this. Using an alias or changing the DocumentRoot in the relevant config files. Either method seems to somewhat work in that you can still access OwnCloud and use it, but the image links are all broken.

For example, I now access OwnCloud here

https://my-owncloud.lan/

But the images are still pointing here:
https://my-owncloud.lan/owncloud/apps/activity/img/activity.svg

The guys at the OC forum are suggesting this is an Apache config issue and advised me to look for help here. I've attached two images to show you what is happening.



If you need anymore info, please let me know

Thanks!

Scott
Back to top
maba



Joined: 05 Feb 2012
Posts: 53
Location: Germany, Heilbronn

PostPosted: Mon 04 Jan '16 20:43    Post subject: Reply with quote

Probably better suited for one of the other categories but anyway.

The link generation is done within owncloud itself. You have to configure OwnCloud to use a different root. (/ instead of /owncloud).

But this is OwnCloud internal.
Back to top
focusrite_sfoster



Joined: 18 Dec 2015
Posts: 3

PostPosted: Tue 05 Jan '16 11:39    Post subject: Reply with quote

Yep, this has been done.
The issue isn't with OwnCloud root as I can access that at /

The issue is with some image links still pointing to /owncloud

Feel free to move this to a more relevant section.
Back to top
focusrite_sfoster



Joined: 18 Dec 2015
Posts: 3

PostPosted: Tue 05 Jan '16 13:13    Post subject: Reply with quote

FWIW, OwnCloud 8.2.2 has fixed this issue. I guess it was a bug.

Cheers
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1