Apache Lounge



Forum Index Downloads Search Register Log in  RSS Apache Lounge

Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.



A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.

mod_wl_22 or mod_ssl

Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules

View previous topic :: View next topic  
Author Message

Joined: 17 Mar 2016
Posts: 2
Location: USA, Reston

PostPosted: Thu 17 Mar '16 20:08    Post subject: mod_wl_22 or mod_ssl Reply with quote

To keep this simple:

Database server:

Solaris 10 u7 5/09
Patchset 147440-19
Java v1.6.0 u45
Oracle DB v11.2.0.4
WebLogic v12.1.1 - this is the Admin console host
OpenSSL v1.0.1g - from sunfreeware.com not the OEM version
Apache v2.2.23 - using mod_wl_22.so as the Proxy to WebLogic and mod_ssl

Application server:

Solaris 10 u7 5/09
Patchset 150400-30
Java v1.6.0 u111
WebLogic v12.1.1 - this is the Application host with 4 Java virtual machines each running a WebLogic server
OpenSSL v1.0.1g - from sunfreeware.com not the OEM version

I pacthed this app server with the latest Solaris patches, and I can no longer connect to my WebLogic cluster through the Apache proxy. I can get to the web page of each server if I go directly to the hostname:port and this works fine so I know the back-end is up. When I type in the URL for Apache it says it is making connection, and waiting for reply. After a few min I get the Failure of Apache Bridge message. This usually means the WL servers are down but they are not.

To trouble shoot:

I tried going directly to each WL page - this works
I tried going to a local page that would access Apache htdocs locally - this works
I tried to see if I could access an App cluster that had NOT been patched by changing the line in httpd.conf where WebLogicCluster is - this works

At this point, I am reasonably sure my Apache itself is working just fine. So I start poking around on the App servers and notice that there were some updates to OpenSSL in the patch set. IDK if this is the root cause, but something was updated on the App server in the patch set that now seems to be the cause, and is now refusing connection where it worked fine prior to the patch.

I am trying to think if I should do 1 of the following:

a) Try to back out the 3-4 packages applied in the update, and then re-install my orig OpenSSL version.
b) Apply the latest patches to the DB server, and re-compile Apache when the new libraries are on the server.

Another person asked about mod_ossl, but I have never compiled that in my Apache. Does this new release of OpenSSL require it?

Any ideas on what is causing it to refuse connections?

Thank you
Back to top

Joined: 17 Mar 2016
Posts: 2
Location: USA, Reston

PostPosted: Tue 29 Mar '16 15:43    Post subject: Reply with quote

For anyone that cares since no one is responding....

Further testing showed:

Apache w/ WL proxy & NO SSL worked like it should, but just like before it won't work with SSL.

Recompiled a new Apache on the App server that has all the updates and no change to behavior. Worked the same as described in the first post.

Downgraded Java on the App server back to JDK6 u45 and everything went back to working?! Re-loaded JDK6 u111 and it stopped working again.
Back to top

Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1