logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Issue to load mod_was_ap22_http.so

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
tridib



Joined: 16 Jun 2016
Posts: 2

PostPosted: Thu 16 Jun '16 16:02    Post subject: Issue to load mod_was_ap22_http.so Reply with quote

Hi All,

I am trying to integrate httpd-2.4.20-win64-VC14 server with WAS 8.5. There I am getting following error when trying to load mod_was_ap22_http.so -
Quote:
%1 is not a valid Win32 application
.
I have tried with mod_was_ap22_http.dll too but with same error. But module mod_was_ap22_http.dll was worked for Apache httpd 2.2 version.
Can anyone help me with suggesting the proper version of mod_was_ap22_http for httpd-2.4.20-win64-VC14 server

Thanks
Tridib
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 16 Jun '16 18:28    Post subject: Reply with quote

Does WAS support http:// or ajp:// protocol? Than you could use a reverse proxy config.
Back to top
tridib



Joined: 16 Jun 2016
Posts: 2

PostPosted: Sat 18 Jun '16 6:15    Post subject: mod_was_ap24_http.so is the required plugin Reply with quote

After some google search I have found mod_was_ap24_http.so is the updated WAS plugin (http://publib.boulder.ibm.com/httpserv/manual24/upgrading.html). But not sure from where to download.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sat 18 Jun '16 12:13    Post subject: Reply with quote

A start point might be http://www-01.ibm.com/support/docview.wss?uid=swg1PI06036
Back to top
covener



Joined: 23 Nov 2008
Posts: 49

PostPosted: Sun 19 Jun '16 14:20    Post subject: Reply with quote

James Blond wrote:
A start point might be http://www-01.ibm.com/support/docview.wss?uid=swg1PI06036


The WAS plugin is a separately installable component of WebSphere. Install it and apply any maintenance from the last 2+ years.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 794
Location: Amsterdam, NL, EU

PostPosted: Tue 21 Jun '16 0:43    Post subject: Re: Issue to load mod_was_ap22_http.so Reply with quote

Quote:
%1 is not a valid Win32 application


This error message indicates in 99% of the cases that you are trying to load a 32-bit module in a 64-bit Apache. It will not work. Moreover, as you found out yourselves, Apache 2.4 needs mod_was_ap24_http.dll (or .so). That one should be available in a 32-bit version somewhere, but propably not as 64-bit:

https://www.ibm.com/developerworks/community/forums/html/topic?id=fa8a8deb-71a9-4dea-9344-a835e025ddd7&ps=100

Quote:
It hasn't ever been supported. There's no 64-bit plugin for Apache on Windows.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1