logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Build error mod_http2 v1.7.0

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Jan-E



Joined: 09 Mar 2012
Posts: 794
Location: Amsterdam, NL, EU

PostPosted: Mon 03 Oct '16 20:24    Post subject: Reply with quote

There is an upgrade of mod_http2 to v1.7.0. If anyone knows how to compile it, please report here:
https://github.com/icing/mod_h2/issues/117
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Tue 04 Oct '16 2:59    Post subject: Reply with quote

Jan,

As to your comment about __dllspec.

That's typically done via XXX_DECLARE that you will see at the beginning of functions on many module. Off the top of my head we have them for AP, APR, DAV, LDAP, PROXY, SSL and I know there are more. For the latter it's in mod_ssl.h and there's always 'extern'.

Now how all this works I partailly understand but when is it needed and by what is still voodoo to me and how Stefan is getting away without it is beyond my understanding, I'm not afraid to admit it.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 04 Oct '16 10:15    Post subject: Reply with quote

Same error here.
Back to top
icing



Joined: 22 Sep 2015
Posts: 38
Location: Münster, Germany

PostPosted: Tue 04 Oct '16 11:21    Post subject: Reply with quote

Please check if v1.7.1 fixes the issue: https://github.com/icing/mod_h2/releases/tag/v1.7.1

As to getting away with things: Cool

My understanding is, the whole *_DECLARE shenanegans are needed to platforms like Windows that do not have a flat linker namespace. DECLARE manages the symbols that need to be visible outside a DLL.

On *NIX platforms, there is only a flat namespace, so this does not really make a difference and no extra thingies are required.

mod_h2, seems to me, can live without DECLARE since its function are module (or DLL) intern only. Except for the OPTIONAL functions that are DECLAREd in order to be used by mod_proxy_http2, for example.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 04 Oct '16 12:19    Post subject: Reply with quote

Build with mod-http2.mak and mod-http2.dep files. Had to remove the response entries in this files.


Was not able to build build with dsp/vcxproj (removed first the response file entries), got link errors. :


Last edited by Steffen on Tue 04 Oct '16 12:39; edited 1 time in total
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 794
Location: Amsterdam, NL, EU

PostPosted: Tue 04 Oct '16 12:28    Post subject: Reply with quote

Steffen wrote:
Build with mod-http2.mak and mod-http2.dep files. Had to remove the response entries in this files.

You'll have to add h2_headers in stead of h2_response
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 04 Oct '16 12:34    Post subject: Reply with quote

yep, building now with GUI. Thanks, I overlooked h2_headers.
Back to top
icing



Joined: 22 Sep 2015
Posts: 38
Location: Münster, Germany

PostPosted: Tue 04 Oct '16 13:22    Post subject: Reply with quote

So, with 1.7.1 we are again clear on all Windows build methods?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 04 Oct '16 17:37    Post subject: Reply with quote

Yep

Note: the dsp/dep/mak files in trunk/branches still needs to be changed.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 794
Location: Amsterdam, NL, EU

PostPosted: Tue 04 Oct '16 21:07    Post subject: Reply with quote

The dsp-file was changed a bit. That was how I found out about h2_headers. Nevertheless I ran into 192 unresolved externals with regenerated project files. Might try it another time to see if the first conversion went wrong somehow.

Anyway running with v1.7.1 now on my dev server with VC9 x86 and VC11 x64.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1