logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Fix crash mod_proxy_{ajp,fcgi} in httpd 2.4.25

 
Post new topic   Reply to topic    Apache Forum Index -> News & Hangout



View previous topic :: View next topic  
Author Message
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Fri 23 Dec '16 14:38    Post subject: Fix crash mod_proxy_{ajp,fcgi} in httpd 2.4.25 Reply with quote

Reported by Konstantin Kolinko :
After upgrade from 2.4.23 to 2.4.25 every request that is proxied to Tomcat results in crash and restart of server child process.

Download Win32/Win64 :

27 Januari included in download.

Applied fix:

mod_proxy_{ajp,fcgi}: Fix a possible crash when reusing an established
backend connection, happening with LogLevel trace2 or higher configured,
or at any log level with compilers not detected as C99 compliant (e.g.
MSVC on Windows).

http://svn.apache.org/viewvc?view=revision&revision=1775775


Last edited by admin on Fri 27 Jan '17 13:25; edited 4 times in total
Back to top
rjung



Joined: 26 Aug 2015
Posts: 2

PostPosted: Fri 23 Dec '16 15:57    Post subject: Re: Fix crash mod_proxy_{ajp,fcgi} in httpd 2.4.25 Reply with quote

Thanks Steffen for quickly providing a fixed binary.

Konstantin has already tested the patch created by Yann using your binary and it fixes the problem.

For curious people: the problem only happens when using mod_proxy_ajp or mod_proxy_fcgi but the bug is in mod_proxy itself. The problem only shows up when either LogLevel is trace2 or above or the compilation is done with a compiler and settings that do not set __STDC_VERSION__ to indicate C99. Especially this is true for Microsofot Visual Studio. So all Windows builds have this problem even with normal LogLevel settings.

Regards,

Rainer
Back to top
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Fri 23 Dec '16 17:20    Post subject: Reply with quote

Thanks for information!
I stop my deployment and wait for VC11 fix.

Merry Christmas!

Greetings from Hamburg
Timo
Back to top
carl.molemans



Joined: 26 Dec 2016
Posts: 2
Location: Vilvoorde

PostPosted: Mon 26 Dec '16 18:41    Post subject: Reply with quote

Is it possible to integrate this fix directly into the download of the 2.4.25 release?

I freaked out when I noticed my httpd didn't come back up Smile

Thanks for this fix by the way, you saved me a whole lot of work
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 27 Dec '16 11:08    Post subject: Reply with quote

I understand your request.

But we want to keep in sync with the official and committed ASF sources.

The fix is not committed yet by the ASF in 2.4.26-dev branche. We expect it is in 2.4.26.
Back to top
carl.molemans



Joined: 26 Dec 2016
Posts: 2
Location: Vilvoorde

PostPosted: Tue 27 Dec '16 16:19    Post subject: Reply with quote

Makes sense, thanks for explaining.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Wed 25 Jan '17 12:23    Post subject: Reply with quote

OpenSSL version 1.0.2k is around the corner, so have to rebuild some.

Maybe also include the mod_proxy fix (is approved) and new PCRE and zlib.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 794
Location: Amsterdam, NL, EU

PostPosted: Wed 25 Jan '17 13:08    Post subject: Reply with quote

PHP is not moving to the new zlib yet:
https://github.com/winlibs/libpng/issues/1#issuecomment-272448486

Luckily, PHP uses a static lib and Apache the dll-version, so they will not byte each other.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Fri 27 Jan '17 13:26    Post subject: Reply with quote

Included now in download
Back to top
CaswellS



Joined: 09 Feb 2017
Posts: 1
Location: US, Colorado Springs

PostPosted: Thu 09 Feb '17 18:51    Post subject: Mod_proxy Reply with quote

After reading the various threads on the mod_proxy issue for 2.4.25 I was left with a question and confused. Was the fix included on the apache lounge downloads or the http://httpd.apache.org/download.cgi#apache24.
Currently we are running 2.4.25 with openssl 1.0.2k but still running into issues that act as if we didn't get the fix.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Thu 09 Feb '17 20:05    Post subject: Reply with quote

It is only in the lounge 27 January download
Back to top


Post new topic   Reply to topic    Apache Forum Index -> News & Hangout
Page 1 of 1