logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: mod_md for httpd 2.4.x Page 1, 2, 3, 4  Next
Author
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Thu 28 Dec '17 14:28    Post subject: mod_md for httpd 2.4.x Reply with quote

Hi,
Please find mod_md VC15 builds (x86 & x64) for apache 2.4.x

Information, install and configuration details in this post and on author's wiki


Last edited by nono303 on Wed 20 Nov '19 10:24; edited 40 times in total
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Thu 28 Dec '17 20:51    Post subject: v1.1.6-git Reply with quote

git repo updated with version 1.1.6-git for testing
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Thu 22 Mar '18 16:27    Post subject: Reply with quote

git repo updated with version 1.1.10 for testing
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Wed 20 Jun '18 16:25    Post subject: Reply with quote

new released version 1.1.12
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Mon 23 Jul '18 15:42    Post subject: Reply with quote

new released version 1.1.15
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2768
Location: Hilversum, NL, EU

PostPosted: Mon 23 Jul '18 15:47    Post subject: Reply with quote

Version 1.1.15 is current in httpd 2.4.34.
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Thu 09 Aug '18 15:02    Post subject: Reply with quote

new released version 1.1.16
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Thu 09 Aug '18 19:02    Post subject: Reply with quote

Downloaded mod_md 1.1.16 and corresponding mod_ssl and placed into the Modules folder for HTTPD 2.4.34 and Apache crashed upon startup. Event Viewer showed faulting module was mod_md.

Reverted back to mod_md 1.1.15 and corresponding mod_ssl and everything worked fine.

Anyone else have issue/s with mod_md 1.1.16?
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Fri 10 Aug '18 9:59    Post subject: Reply with quote

Hi,

Effectively, a too fast git push with not all file commited...
1.1.16 had been updated so could you please download again and give me a feedback?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2768
Location: Hilversum, NL, EU

PostPosted: Fri 10 Aug '18 10:58    Post subject: Reply with quote

Try the one from the by ASF committed one in svn:

www.apachelounge.com/download/VC15/modules/mod_md-1.1.16-win64-VC15.zip


No need to update mod_ssl 2.4.34.
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Fri 10 Aug '18 17:42    Post subject: Reply with quote

Nono303:

I downloaded the updated mod_md 1.1.16 and tried running with and without the corresponding mod_ssl and once gain Apache crashed upon startup Sad. Event Viewer showed faulting module was mod_md.

Steffen:

I downloaded the ASF version of mod_md 1.1.16 and everything worked fine Smile.
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Tue 27 Nov '18 10:57    Post subject: Reply with quote

new released version 1.1.17.
AVX & !AVX build to resolve reported issues
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Tue 27 Nov '18 20:32    Post subject: Reply with quote

Nono303:


I am running Apache 2.4.37 x64 w/OpenSSL 1.1.1a (November 21, 2018 build from ApacheLounge).

I downloaded the updated mod_md 1.1.17 from the link you provided and tried running with and without the corresponding mod_ssl along with the DEPS jansson.dll & libcurl.dll files and once again Apache crashed upon startup Neutral Neutral Neutral. Event Viewer showed faulting module was mod_md (mod_md could not be found and incorrect function).

I reverted back to my previous version of mod_md, mod_ssl, & associated .DLL files and everything worked fine.

No changes were made to my HTTPD.conf. Am I doing something wrong?
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Wed 28 Nov '18 16:53    Post subject: Reply with quote

Hi DnvrSysEngr,

Thanks for your feedback! I can reproduce the error with Apache Lounge distrib but actually don't understand why it occur. I'll try changing some flags or compile mode and give you some news
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Wed 12 Dec '18 18:33    Post subject: Reply with quote

I finally found the issue (but don't yet understand it...)
Renaming libcrypto-1_1-x64.dll and libssl-1_1-x64.dll respectively to libcrypto-1_1.dll and libssl-1_1.dll (without -x64 even if they are x64 bin) works for provided mods.
Iíll investigate to understand this stange things and push a compatible mod with standard openssl dll name ^^
Back to top
nono303



Joined: 20 Dec 2016
Posts: 102
Location: France, Lille

PostPosted: Thu 13 Dec '18 19:23    Post subject: Reply with quote

Hi DnvrSysEngr,
I finally fix the issue (detail)
Could you confirm that my last commit pushed and tagged on v1.1.17 is now fully functional with standard apache lounge release?
Thanks in advance
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Thu 13 Dec '18 19:59    Post subject: Reply with quote

Nono303:

I will test later this afternoon for you.

-S
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Fri 14 Dec '18 23:55    Post subject: Reply with quote

Happy Friday Nono303:

Is it a Happy Friday???

I am running Apache 2.4.37 x64 w/OpenSSL 1.1.1a (November 21, 2018 build from ApacheLounge).

Per your request yesterday, I downloaded the updated mod_md 1.1.17 from the link you provided and tried running with and without the corresponding mod_ssl along with the DEPS jansson.dll & libcurl.dll files and once again Apache crashed upon startup Neutral Neutral Neutral. Event Viewer showed this: Cannot load modules/mod_md.so into server: The specified module could not be found. .

I reverted back to my previous version of mod_md, mod_ssl, & associated .DLL files and everything worked fine.

No changes were made to my HTTPD.conf. Am I doing something wrong?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 982
Location: Amsterdam, NL, EU

PostPosted: Sat 15 Dec '18 8:10    Post subject: Reply with quote

DnvrSysEngr wrote:
Event Viewer showed this: Cannot load modules/mod_md.so into server: The specified module could not be found.

Try to open the mod_md.so in a text editor like Notepad++ and search for the string 'libcrypto-1_1-x64.dll'. It should be there.
Back to top
DnvrSysEngr



Joined: 15 Apr 2012
Posts: 202
Location: Denver, CO USA

PostPosted: Sat 15 Dec '18 10:29    Post subject: Reply with quote

Jan-E

I have opened mod_md.so with Notepad++, but I am not about to try to edit the file, as I am not a programmer and have no idea what I am doing.
Back to top


Reply to topic   Topic: mod_md for httpd 2.4.x View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads Page 1, 2, 3, 4  Next