Apache Lounge



Forum Index Downloads Search Register Log in  RSS Apache Lounge

Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.



A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.

apache webdav

Post new topic   Reply to topic    Apache Forum Index -> Apache

View previous topic :: View next topic  
Author Message

Joined: 15 Jan 2018
Posts: 3
Location: usa, mn

PostPosted: Wed 17 Jan '18 12:57    Post subject: apache webdav Reply with quote

okay, i am flummoxed...i have been using webdav forever and it has always been pretty straight forward set-up in fact i have used the same configuration file with a few edits since red hat 7. i just updated (not from rh 7 but..) to fedora 27 server from fedora 24. everything worked fine in fc24 however i will be damned if i can get the webdav to write to in fc27. this is the error i keep getting...

[Wed Jan 17 04:39:28.449595 2018] [dav:error] [pid 6908:tid 140437503338240] [client XXX.XXX.XXX.XXX:56270] The locks could not be queried for verification against a possible "If:" header.  [500, #0]
[Wed Jan 17 04:39:28.449606 2018] [dav:error] [pid 6908:tid 140437503338240] [client XXX.XXX.XXX.XXX:56270] Could not open the lock database.  [500, #400]
[Wed Jan 17 04:39:28.449610 2018] [dav:error] [pid 6908:tid 140437503338240] (20019)DSO load failed: [client XXX.XXX.XXX.XXX:56270] Could not open property database.  [500, #1]

okay, i have searched that relentlessly and cannot get any solution to work. the issue is i cannot write to my davsite.

i assume from that error that it is not creating the lockdb so i set the directory to chmod 777 and that didnt work. i chown'ed to apache user:apache user and that didnt work...nothing has worked for this error. i am hoping someone can help me because i literally use my davsite daily and cannot now.

recently, i split my httpd.conf and removed the virtual host configuartions from that and put them in the conf.d directory where they are supposed to be. so this is my main websites conf file...

DavLockDB /var/lib/dav/lockdb

Alias /xxxxxxxx /var/www/xxxxxxx
<VirtualHost *:80>
        ServerAdmin root@xxxxxxxxxx.com
        ServerName www.xxxxxxxxxxx.com
        ServerAlias xxxxxxxxxx.com
        Redirect permanent "/xxxxxxxx" "https://xxxxxxxxxxxx.com/xxxxxxxxxxx"

<VirtualHost *:443>
        ServerAdmin root@xxxxxx.com
        Servername www.xxxxxxxxxxxxx.com
        ServerAlias xxxxxxxxxxx.com
        DocumentRoot /var/www/xxxxxx

        ErrorLog "/var/log/httpd/XXXXXXXXX.log"
        CustomLog "/var/log/httpd/XXXXXXXXX.log" combined

        SSLEngine On
        SSLCipherSuite HIGH:!aNULL:!MD5
        SSLHonorCipherOrder On
        SSLProtocol -All +TLSv1 +TLSv1.1 +TLSv1.2
        SSLCertificateFile "/etc/ssl/certs/xxxxxx.crt"
        SSLCertificateKeyFile "/etc/ssl/certs/xxxxxx.key"
        SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

        Dav On
        AuthType Digest
        AuthDigestProvider file
        AuthUserFile xxxxxxxxxxxxxxxxxxxx
        Require user xxxxx
        BrowserMatch "MSIE" AuthDigestEnableQueryStringHack=On

#       DirectoryIndex disabled
        Options Indexes FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from All

#      <LimitExcept GET POST OPTIONS>
#       Require user XXXXXX
#      </LimitExcept>
#    <IfModule mod_security2.c>
#       SecRuleRemoveById 960032 960038 960904
#    </IfModule>

obviously i have redacted some info but that should be enough to give you the idea. i have tried much and like i have said, cannot figure this out. it has always worked off this but WILL NOT now...[/code]
Back to top

Joined: 15 Jan 2018
Posts: 3
Location: usa, mn

PostPosted: Fri 02 Feb '18 14:26    Post subject: solved Reply with quote

after searching for what seemed like years and years and years and years i finally fingered it out. APPARENTLY, apache uses apr-util to build a berkeley db for the dav lock db...of course, right?! well, the issue with that is httpd does NOT have a dependency of apr-util-bdb. why is that important, well those are the drivers for the apr-util. without those apr-util was not working right and not building the davlockdb. once i installed those and restarted the pc, dav once again works. HOORAY FOR ME!

Back to top

Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1