logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Rewrites not Working in Apache 2.4.29 Win64 VC15

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
cwickenh



Joined: 24 Jan 2018
Posts: 2

PostPosted: Thu 25 Jan '18 19:22    Post subject: Rewrites not Working in Apache 2.4.29 Win64 VC15 Reply with quote

Hello, I am trying to upgrade from Apache 2.4.18 Win64 VC15 running on Windows Server 2008 to Apache 2.4.29 Win64 VC15 running on Windows Server 2016.

I can't get Rewrites to work on version 2.4.29 that are currently working in version 2.4.18.

I feel that I have tried everything! Of course, I'm loading the mod_rewrite module. I've tried enabling tracing using LogLevel Debug rewrite:trace2 all the way to LogLevel Debug rewrite:trace8, but no rewrite events show up in my error log. Could it be that there is something missing in this compiled package of Apache, or that I'm missing something that is a new undocumented requirement? PLEASE be something simple! I've been battling this for weeks, with no success.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2690
Location: Hilversum, NL, EU

PostPosted: Fri 26 Jan '18 11:28    Post subject: Reply with quote

No other report that mod_rewrite has issues.
Back to top
cwickenh



Joined: 24 Jan 2018
Posts: 2

PostPosted: Fri 26 Jan '18 17:53    Post subject: Reply with quote

Thanks for the reply.

I see that no others are reporting it, but not sure if that's enough to assume that it isn't a problem?

How could you explain there not being ANY rewrite entries in my error log when I enable rewrite:trace3?

Could you give it a try on a Windows 2016 Server? Perhaps it's combination of the OS and the Apache?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2690
Location: Hilversum, NL, EU

PostPosted: Sat 27 Jan '18 12:52    Post subject: Reply with quote

Rewrite works here on 2016 server and entries [rewrite:trace2/3] in the log.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6460
Location: Germany, Next to Hamburg

PostPosted: Thu 08 Feb '18 16:18    Post subject: Reply with quote

check with
Code:
httpd -M
if the module is loaded.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1