logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Compile 2.4.33 w/openssl 1.0.2o error

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
CaswellS



Joined: 09 Feb 2017
Posts: 2
Location: US, Colorado Springs

PostPosted: Sat 26 May '18 0:55    Post subject: Compile 2.4.33 w/openssl 1.0.2o error Reply with quote

I'm trying to compile httpd-server 2.4.33 with VS Express 2012 and running into an error with

config.obj : error LNK2019: unresolved external symbol _ap_get_module_flags@4 referenced in function _merge_server_configs
with openssl 1.0.2o. Has anyone else encountered this problem or found a workaround?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2170
Location: Sun Diego, USA

PostPosted: Sat 26 May '18 2:11    Post subject: Reply with quote

No, but that function (ap_get_module_flags) is in util_debug.c, is that failing to build? Look for util_debug.obj in httpd-2.4.33/server/Release (or Debug depending on the target). If you do not find it, why is that failing to compile?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1