logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Cannot load c:/[existingpath]/php7ts.dll into server

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
tacitus5



Joined: 15 Oct 2018
Posts: 2
Location: Germany, Bremen

PostPosted: Mon 15 Oct '18 19:42    Post subject: Cannot load c:/[existingpath]/php7ts.dll into server Reply with quote

Hello all,

I have a problem I don't understand with Apache 2.4 and php 7 running (or not running) as service on localhost.

I have two Windows systems, on whch I tried to install and run the same server files:
1. Windows 10 Home Version 1803
2. Windows Vista Home Premium

Microsoft Visual C++ 2017 Redistributable (x86) 14.15.26706
is installed on both machines. I don't know f this is neccessary for just running Apache 2.4 or oly if you want to complie APache 2.4 from source.

I downloaded
Apache 2.4.34 Win32 - Build Date Jul 18 2018 09:59:02
some weeks ago from https://www.apachelounge.com/download/

php version is php7.2.8.0 (32bit)

This configuration is running fine on Windows 10 as a service installed by
"apache\bin\httpd -k install -n ApachePSG"
and started with
"net start ApachePSG"

via windows batch file.

If I try to run the same programs on Windows Vista
the service is installed but stopped immediately and I get the following error message in an MSDOS-shell:

"testing httpd.conf. Errors herein must be corrected before the service can be started.
httpd: syntax error on line [some number] of httpd.conf: Cannot load [PathToPhp]/php7ts.dll into server"

The [PathToPhp] does exist and the file php7ts.dll is in that path for both windows versions.


The Apche2.4 files and php files are the same for both windows versions.

I'm at a loss to find out what really happens on Windows Vista, while the same configuration file on Windows10 does not throw any error and runs as expected.

Any idea what might go wrong?
Or any idea what I can try to get around this problem?
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 567

PostPosted: Mon 15 Oct '18 20:51    Post subject: Reply with quote

They removed support for Vista in 7.2 +

See http://php.net/manual/en/install.windows.requirements.php
Back to top
tacitus5



Joined: 15 Oct 2018
Posts: 2
Location: Germany, Bremen

PostPosted: Tue 16 Oct '18 18:36    Post subject: Reply with quote

The removal of support for Vista in php7.2+ explains everything.

Thanks for the hint.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1