logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



allow transport "upgrade".

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
edwardsmarkf



Joined: 20 Feb 2013
Posts: 16
Location: cottonwood, az

PostPosted: Fri 18 Jan '19 18:37    Post subject: allow transport "upgrade". Reply with quote

hello -

the socket.io people have told me i need to:

Quote:
You need to upgrade and allow transport "upgrade".


what steps must i take to cause this to happen? is this something that has to be compiled into Apache, or is it just a line in the httpd.conf file?

thank you very much.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6552
Location: Germany, Next to Hamburg

PostPosted: Sat 19 Jan '19 9:55    Post subject: Reply with quote

The only thing that does this is mod_http2
The directive is H2Direct[1]



[1] https://httpd.apache.org/docs/2.4/mod/mod_http2.html#h2direct
Back to top
edwardsmarkf



Joined: 20 Feb 2013
Posts: 16
Location: cottonwood, az

PostPosted: Sat 19 Jan '19 18:17    Post subject: Reply with quote

thank you very much for your reply. are you saying all of my httpd.conf additions can be replaced simply by inserting
Code:
H2Direct on
?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6552
Location: Germany, Next to Hamburg

PostPosted: Sat 19 Jan '19 18:52    Post subject: Reply with quote

it requires that you have loaded mod_http2

Code:

ProtocolsHonorOrder On
Protocols h2c h2 http/1.1
H2Direct On
Back to top
edwardsmarkf



Joined: 20 Feb 2013
Posts: 16
Location: cottonwood, az

PostPosted: Sat 19 Jan '19 22:12    Post subject: Reply with quote

got back this message:

Quote:
Invalid command 'ProtocolsHonorOrder', perhaps misspelled or defined by a module not included in the server configuration
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6552
Location: Germany, Next to Hamburg

PostPosted: Sun 20 Jan '19 15:13    Post subject: Reply with quote

ProtocolsHonorOrder is only available from Apache 2.4.17 and later.
Back to top
edwardsmarkf



Joined: 20 Feb 2013
Posts: 16
Location: cottonwood, az

PostPosted: Tue 22 Jan '19 0:35    Post subject: Reply with quote

thank you very much James - i should have known this might have been a version issue.

here is my original question:
https://www.apachelounge.com/viewtopic.php?p=37732#37732

note - james, you have been an invaluable resource for my apache questions in apachelounge.com for a LONG time now -- thank you so much for your dedication.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1