logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Other Software View previous topic :: View next topic
Reply to topic   Topic: PHP handlers php5apache2_4.dll Win32 for Apache 2.4
Author
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2761
Location: Hilversum, NL, EU

PostPosted: Wed 15 Feb '12 14:25    Post subject: PHP handlers php5apache2_4.dll Win32 for Apache 2.4 Reply with quote

The modules php5apache2_4.dll handlers for Apache 2.4 with PHP version 5.4, 5.3 and 5.2 now available.


Works only with Win32 Apache 2.4.1+.


Steffen
Back to top
Kagome



Joined: 20 Jul 2012
Posts: 8

PostPosted: Sat 18 Aug '12 22:22    Post subject: Reply with quote

maybe a stupid question, but how do you make those handlers?
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 595

PostPosted: Sun 19 Aug '12 10:52    Post subject: Reply with quote

Just doing a regular php build against 2.4.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2761
Location: Hilversum, NL, EU

PostPosted: Thu 29 Nov '12 13:49    Post subject: Reply with quote

Added php handlers for 5.3.19 and 5.4.9 to the .zip at the download page.

Steffen
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2761
Location: Hilversum, NL, EU

PostPosted: Fri 21 Dec '12 12:49    Post subject: Reply with quote

Added php handler for 5.3.20 to the .zip at the additional download page.

Steffen
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Fri 21 Dec '12 13:32    Post subject: Reply with quote

Would not it be better to add the 5.4.10 dll as well? After all, your Apache builds are VC10 and the DLL in the php.net distribution is VC9.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2761
Location: Hilversum, NL, EU

PostPosted: Fri 21 Dec '12 13:46    Post subject: Reply with quote

Nope, the .dll here are also VC9, see the comment at the download:

VC9 - PHP Handler modules PHP 5.2, 5.3 and 5.4 for Apache 2.4

VC9 builds are provided here at Apache Lounge, see the Additional download page and are used by PHP and others who are still prefer VC9.


Steffen
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Fri 21 Dec '12 13:54    Post subject: Reply with quote

Oops. You are right.

Jan
Back to top
mmoreno



Joined: 13 Feb 2013
Posts: 2
Location: USA, Columbus Ohio

PostPosted: Wed 13 Feb '13 20:15    Post subject: Reply with quote

Any timeframe for when a 2.4 handler will be available for php 5.3.21?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2761
Location: Hilversum, NL, EU

PostPosted: Wed 13 Feb '13 20:43    Post subject: Reply with quote

Available now at the Additional download page.


Steffen
Back to top
mmoreno



Joined: 13 Feb 2013
Posts: 2
Location: USA, Columbus Ohio

PostPosted: Wed 13 Feb '13 22:17    Post subject: Reply with quote

Wow that was fast - thanks!
Back to top
eeyet



Joined: 23 Jan 2019
Posts: 1
Location: Ukraine

PostPosted: Wed 23 Jan '19 17:07    Post subject: Reply with quote

Hello,
I couldn`t find dll files for PHP 5.3.29 in
php5apache2_4.dll-php-5.3-win32.zip
The last version in this archive is 5.3.21
Is anywhere else I could find dll module for this PHP version?
Plese help
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6673
Location: Germany, Next to Hamburg

PostPosted: Thu 24 Jan '19 10:22    Post subject: Reply with quote

eeyet wrote:
Hello,
I couldn`t find dll files for PHP 5.3.29 in
php5apache2_4.dll-php-5.3-win32.zip
The last version in this archive is 5.3.21
Is anywhere else I could find dll module for this PHP version?
Plese help


You can run that old PHP version over mod_fcgid
See https://www.apachelounge.com/viewtopic.php?t=2394
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Thu 24 Jan '19 12:15    Post subject: Reply with quote

eeyet wrote:
Hello,
I couldn`t find dll files for PHP 5.3.29 in
php5apache2_4.dll-php-5.3-win32.zip
The last version in this archive is 5.3.21
Is anywhere else I could find dll module for this PHP version?

https://windows.php.net/downloads/releases/archives/

To be precise:
https://windows.php.net/downloads/releases/archives/php-5.3.29-Win32-VC9-x86.zip
Back to top


Reply to topic   Topic: PHP handlers php5apache2_4.dll Win32 for Apache 2.4 View previous topic :: View next topic
Post new topic   Forum Index -> Other Software