logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Shibboleth-Apache HTTP server- not loading mod_shib_24.so

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
uday



Joined: 11 Mar 2019
Posts: 2

PostPosted: Tue 12 Mar '19 9:08    Post subject: Shibboleth-Apache HTTP server- not loading mod_shib_24.so Reply with quote

Hi,

We are trying to configure Shibboleth as service provider for my ESO configuration on Windows Server (64bit) with Apache HTTP server 2.4. When I try to load shibboleth module 'mod_shib' with Apache HTTP server, the server doesn't start at all and below error message is logged with MS Event viewer:

httpd.exe: Syntax error on line 174 of C:/Apache24/conf/httpd.conf: Cannot load C:/opt/shibboleth-sp/lib/shibboleth/mod_shib_24.so into server: The Apache service named is not a valid Win32 application.

On line 174 of httpd.conf file, we have:
LoadModule mod_shib C:/opt/shibboleth-sp/lib/shibboleth/mod_shib_24.so

We have installed Shibboleth SP as well as Apache HTTP server 2.4 of 64 bit version only. But even after that, error message from Apache HTTP server is considering the mod_shib_24.so file as a Win32 application file. This is strange and we are struck at this point.

Please help us with your valuable inputs on how to get this working.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2192
Location: Sun Diego, USA

PostPosted: Tue 12 Mar '19 10:27    Post subject: Reply with quote

"The Apache service named is not a valid Win32 application". That's just leftover from the Win32 only days.

You see that and chances are you're missing a dll file, in this case 3. They are not missing, just Apache cannot find them. They are;

shibsp-lite3_0.dll
xerces-c_3_2.dll
xmltooling-lite3_0.dll

Two ways to deal with this.

1 and easiest is copy the files from Program Files\Shibboleth\SP\lib and place them in Apache's bin folder.

2 Use LoadFile in Apache's httpd.conf after the LoadModule for mod_shib_24 like

LoadFile "c:/program files/shibboleth/sp/lib/shibsp-lite3_0.dll"

for them all. The advantage to this would be when you updated shibboleth, Apache would use the updated dlls.
Back to top
uday



Joined: 11 Mar 2019
Posts: 2

PostPosted: Fri 15 Mar '19 18:15    Post subject: Reply with quote

Thanks so much for the help @glsmith. We'd try this out very soon and update you Smile

BTW, how did you come to this conclusion that it's missing these dll files. Very curious to know as I am novice in this regard and had no clue at all before posting this query on ApacheLongue Smile
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2192
Location: Sun Diego, USA

PostPosted: Sat 16 Mar '19 7:04    Post subject: Reply with quote

Downloaded a copy of shibboleth.
Used Dependency Walker to see what the module is linked to.



The green is from Apache
Blue is the Visual C++ redistributable
What's left you will find in \Program Files\Shibboleth\SP\lib
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1