logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Error building libaprutil-1.dll (Apache 2.4.38 - Win64 bits)

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
alan_bugs



Joined: 30 Apr 2019
Posts: 1
Location: México

PostPosted: Tue 30 Apr '19 23:41    Post subject: Error building libaprutil-1.dll (Apache 2.4.38 - Win64 bits) Reply with quote

I come from the question about Building Apache 2.4.38 for Windows 64 bit https://www.apachelounge.com/viewtopic.php?t=8237

And I try to compile Apache following this steps -> https://www.apachelounge.com/viewtopic.php?t=6462

I hope to count on your valuable support because I'm a novice in this of Apache and it's the first time I try to compile it. Following first steps I don't find fault, until to number 9 and then the console sends me the following message when I excecute "nmake". Crying or Very sad

Please, please be specific if I should edit any file Sad

Thank you and sorry for my bad english. Embarassed

--------------------------------------------------------
[ 46%] Linking C shared library libaprutil-1.dll


LINK Pass 1: command "C:\PROGRA~2\MICROS~1.0\VC\bin\amd64\link.exe /nologo @CMakeFiles\libaprutil-1.dir\objects1.rsp /out:libaprut
il-1.dll /implib:libaprutil-1.lib /pdb:C:\Development\Apache24\build\apr-util\libaprutil-1.pdb /dll /version:0.0 /machine:x64 /deb
ug /INCREMENTAL C:\Apache24\lib\libapr-1.lib C:\Program Files (x86)\Expat 2.2.6\Bin\libexpat.lib kernel32.lib user32.lib gdi32.lib
winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib advapi32.lib /MANIFEST /MANIFESTFILE:CMakeFiles\libaprutil-
1.dir/intermediate.manifest CMakeFiles\libaprutil-1.dir/manifest.res" failed (exit code 1120) with the following output:


building library libaprutil-1.lib and object libaprutil-1.exp

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_ParserCreate referenced in function apr_xml_parser_create

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_SetEntityDeclHandler referenced in function apr_xml_parser_create

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_SetElementHandler referenced in function apr_xml_parser_create

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_SetCharacterDataHandler referenced in function apr_xml_parser_create

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_SetUserData referenced in function apr_xml_parser_create

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_Parse referenced in function do_parse

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_StopParser referenced in function entity_declaration

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_GetErrorCode referenced in function do_parse

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_ParserFree referenced in function cleanup_parser

apr_xml.c.obj : error LNK2019: unresolved external symbol XML_ErrorString referenced in function apr_xml_parser_geterror libaprutil-1.dll : fatal error LNK1120: 10 external unresolved
NMAKE : fatal error U1077: '"C:\Program Files\cmake-3.14.3-win64-x64\bin\cmake.exe"' : returned code '0xffffffff' Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\BIN\amd64\nmake.exe"' : returned code '0x2' Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\BIN\amd64\nmake.exe"' : returned code '0x2' Stop.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2196
Location: Sun Diego, USA

PostPosted: Wed 01 May '19 21:35    Post subject: Reply with quote

https://www.apachelounge.com/viewtopic.php?t=6462
That must have been written before apr-util 1.6.

Your missing Expat which is required by apr-util.

These days it's a pain in the backside but this should give you an idea. Specifically my posts at https://www.apachelounge.com/viewtopic.php?t=7827
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1