logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



ap_send_http_header doesn't send new headers

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Lyudmila.Fokina



Joined: 10 Apr 2019
Posts: 6
Location: USA

PostPosted: Tue 06 Aug '19 21:16    Post subject: ap_send_http_header doesn't send new headers Reply with quote

I am adding some headers to headers_out using
apr_table_set(headers_out, key, value)
I check that the new header is there calling
apr_table_getm(request, headers_out, key)

Now I am sending the headers back to the client
ap_send_http_header(request)
return status

But I don't see the newly added header in the response client receive.
Any ideas what could be wrong?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6628
Location: Germany, Next to Hamburg

PostPosted: Wed 21 Aug '19 10:24    Post subject: Reply with quote

Did you already take a look at https://httpd.apache.org/docs/2.4/developer/modguide.html ?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1