logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Third-party Modules View previous topic :: View next topic
Reply to topic   Topic: FcgidFixPathinfo = 1 alters asset paths to c:/sites/default/
Author
sam452



Joined: 19 Dec 2016
Posts: 20
Location: US, Nashville

PostPosted: Thu 03 Oct '19 14:05    Post subject: FcgidFixPathinfo = 1 alters asset paths to c:/sites/default/ Reply with quote

I've stood up an Apache 2.4 server on Windows running Drupal 8.7 and PHP 7.2 nts per James Blond's excellent post. This post is a descendant from https://www.apachelounge.com/viewtopic.php?t=8362 and is focused on this one question. I'm getting timeouts on some complex pages and POST on editing entities, even increasing the timeout in PHP, Apache to 300 seconds. I have RAM to spare. I've set up PHP 7.2 nts for production because that's what's recommended.

When
Code:
cgi.fix_pathinfo = 1
in php.ini, which is recommended, the Apache docs say that
Code:
FcgidFixPathinfo = 1
in httpd.conf. When I restart Apache, clear Drupal's cache so that its API for managing assets for production, then Drupal cannot find any assets in

Code:
c:/sites/default/files/myfile.css
c:/sites/default/files/otherfile.png


which is absolutely wrong. Normally it should read
Code:
/sites/default/files/myfile.css


Returning
Code:
FcgidFixPathinfo 0


returns Drupal to its expected state, but saving entities, viewing complex pages, will timeout at 300 seconds.

This is a quote from the apache.org docs on this directive.

Quote:
FcgidFixPathinfo should mirror the cgi.fix_pathinfo setting in php.ini.


I've ensured this is set in its .htaccess at its root:

Code:
RewriteBase /


with no change after clearing all cache.

These are the relevant apache conf and php.ini settings.
https://gist.github.com/sam452/98d7979a8458ff21aaf89201d1f77b96

I figure this setting and its counterpart in php.ini to match should help with mod_fcgid's handling of complex POST?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6661
Location: Germany, Next to Hamburg

PostPosted: Fri 04 Oct '19 22:57    Post subject: Reply with quote

From my experience you should set in the apache config FcgidFixPathinfo 0
and cgi.fix_pathinfo=1 in php.ini

Does your rewrite code look like this?
Code:

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php?page=$1 [QSA]


Maybe you need to increase

FcgidMaxRequestLen

See also https://www.apachelounge.com/viewtopic.php?t=2394

if you still have a question please ask again.
Back to top


Reply to topic   Topic: FcgidFixPathinfo = 1 alters asset paths to c:/sites/default/ View previous topic :: View next topic
Post new topic   Forum Index -> Third-party Modules