logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: OpenSSL 1.1.1 < 1.1.1e-dev Procedure Overflow Vulnerabili
Author
franklin.watson



Joined: 27 Jan 2020
Posts: 1
Location: us, mechaincsville

PostPosted: Tue 11 Feb '20 18:20    Post subject: OpenSSL 1.1.1 < 1.1.1e-dev Procedure Overflow Vulnerabili Reply with quote

Medium Nessus Plugin ID 132725
Synopsis
The remote service is affected by a procedure overflow vulnerability.
Description
The version of OpenSSL installed on the remote host is prior to 1.1.1e-dev. It is, therefore, affected by a vulnerability as referenced in the 1.1.1e-dev advisory.

- There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely.
Attacks against DH512 are considered just feasible.
However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway.
Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME.
Fixed in OpenSSL 1.1.1e-dev (Affected 1.1.1-1.1.1d).
(CVE-2019-1551)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
Solution
Upgrade to OpenSSL version 1.1.1e-dev or later.

How would i go about updating to the newest version of openSSl
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 597

PostPosted: Tue 11 Feb '20 18:59    Post subject: Reply with quote

See https://www.apachelounge.com/viewtopic.php?p=38826
Back to top


Reply to topic   Topic: OpenSSL 1.1.1 < 1.1.1e-dev Procedure Overflow Vulnerabili View previous topic :: View next topic
Post new topic   Forum Index -> Apache