logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: pcre.dll missing using vc14 compilation
Author
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Fri 12 Jun '20 18:38    Post subject: pcre.dll missing using vc14 compilation Reply with quote

Hi Team,

Need a help to fix the pcre.dll. Compiling the Apache 2.4.43. For that i need a pcre latest version.

I have compiled the pcre binaries thru VC14. compilation success and got the library files. But prce.dll is missing. Finally apache copy failed with pcre.dll.

Hence tried to compile the PCRE thru cmake commandline and prce.sll created. but apache compilation facing the following issue.

Creating library .\Release\libhttpd.lib and object .\Release\libhttpd.exp util_pcre.obj : error LNK2001: unresolved external symbol _pcre_free
.\Release\libhttpd.dll : fatal error LNK1120: 1 unresolved externals

Kindly help me to fix the issue.

Thanks,
Anitha.S
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2243
Location: Sun Diego, USA

PostPosted: Sat 13 Jun '20 18:17    Post subject: Reply with quote

I compile with cmake from the command line.

cmake -G "NMake Makefiles" -DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=ON -DPCRE_BUILD_PCRECPP=OFF -DPCRE_BUILD_PCREGREP=OFF -DPCRE_SUPPORT_UTF=ON -DPCRE_SUPPORT_JIT=ON -DPCRE_SUPPORT_BSR_ANYCRLF=ON -DPCRE_SUPPORT_UNICODE_PROPERTIES=ON -DPCRE_REBUILD_CHARTABLES=ON

the above is all 1 line, then just;

nmake

you will get pcre.dll, pcre.lib and pcre.pcb

-DBUILD_SHARED_LIBS=OFF gives a static lib file
-DBUILD_SHARED_LIBS=ON gives the dll & a linking lib
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Mon 15 Jun '20 7:47    Post subject: Reply with quote

Hi Smith,

Its works Smile. thanks a lot let me compile the entire apache and come back in case any issues.

Once again thanks.
Anitha.S
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Thu 25 Jun '20 14:53    Post subject: Reply with quote

HI Smith,

Thanks for support. I have compiled and loaded the supporting packages.

Now tried to compile apr and apr-util. Apr compiled fine. But apr-util when i load on vc and build all shows many error related to db.

Do i need to install any mysql version. As i refer many apache lounge post and confused.

And i am compiling the Apr binaries first time since previously we use pre-compiled binaries. So your reply will be very much useful.

Thanks
Anitha.S
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Thu 25 Jun '20 16:27    Post subject: Reply with quote

Also can i use opelSSL 102 version? instead of 1.1.1g ?? Since my project still using openssl 102 and i checked 1.1.1 the binaries libeay and ssleay names are modified.

Hence i have a lots of changes need to do in my project due to the openssl change.

Kindly suggest your ideas on this.

Thanks,
Anitha.S
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2243
Location: Sun Diego, USA

PostPosted: Thu 25 Jun '20 19:07    Post subject: Reply with quote

APR DB errors: You should have no errors unless you are asking for more than just the ocdb connector to be built by changing 0s to 1s in apu.hw

#define APU_HAVE_PGSQL 0
#define APU_HAVE_MYSQL 0
#define APU_HAVE_SQLITE3 0
#define APU_HAVE_SQLITE2 0
#define APU_HAVE_ORACLE 0

If you change any of these, yes you will need the .lib dependencies they require. But first get through a complete compile without adding these.

OpenSSL: Yes it still is wanting OpenSSL 1.0.x and yes that can be changed. There is a tool in srclib/apr/build/cvtdsp.pl that will work. Before you open the .dsw file in Visual Studio and do the conversion from the command line

perl /srclib/apr/build/cvtdsp.pl -ossl11

That will adjust the mod_ssl & apr_crypto_openssl dsp files to use libcrypto.lib & libssl.lib.

I think I will just change that right now in the dsp files so the next Apache version will just look for those now that all 1.0.x versions of OpenSSL are EOL.

Again, I have not used the IDE in years. Steffen's the better person to ask since he's still using them and maybe he ill jump in if I have gotten anything wrong.
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Fri 26 Jun '20 6:44    Post subject: Reply with quote

Hi Smith,

Thanks a ton for the immediate reply. Will do the same and start the compilation.

Thanks,
Anitha.S
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Fri 26 Jun '20 20:12    Post subject: Reply with quote

Hello Smith,

cmake compilation for apr,apr-util and etc, httpd went fine and its created the necessary.

Finally compared and check there some missing folders and files. Tried modify the cmakelists files of apr-util and no results Sad.

Missing iconv folder under apache24\bin and libapriconv-1.dll & lib files are missing and i check cmakelist of apr-util has no proper entries for iconv. Any suggestion to try the code would be helpful.


Thanks in Advance,
Anitha.S
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 29
Location: india

PostPosted: Sun 28 Jun '20 18:50    Post subject: Reply with quote

Immediate reply will be helpful friends .

Thanks in Advance,
Anitha.S
Back to top


Reply to topic   Topic: pcre.dll missing using vc14 compilation View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads