logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Third-party Modules View previous topic :: View next topic
Reply to topic   Topic: mod_md error: error loading staged set
Author
EIKA



Joined: 22 Jan 2019
Posts: 35
Location: Russia

PostPosted: Wed 05 Aug '20 22:13    Post subject: mod_md error: error loading staged set Reply with quote

Hi all!

I come across with new issue. From time to time Apache shut down accidentally. And I can't run it again.

In error_log I see:

Code:
[mpm_winnt:notice] [pid 5880:tid 476] AH00455: Apache/2.4.43 (Win64) OpenSSL/1.1.1g configured -- resuming normal operations
[mpm_winnt:notice] [pid 5880:tid 476] AH00456: Apache Lounge VS16 Server built: Apr 21 2020 16:23:13
[core:notice] [pid 5880:tid 476] AH00094: Command line: 'D:\\Apache\\bin\\httpd.exe -d D:/Apache'
[mpm_winnt:notice] [pid 5880:tid 476] AH00418: Parent: Created child process 6604
[md:error] [pid 6604:tid 380] (OS 80)The file exists.  : AH10069: domain.dom: error loading staged set
[:notice] [pid 6604:tid 380] ModSecurity for Apache/2.9.3 (http://www.modsecurity.org/) configured.
[:notice] [pid 6604:tid 380] ModSecurity: APR compiled version="1.7.0"; loaded version="1.7.0"
[:notice] [pid 6604:tid 380] ModSecurity: PCRE compiled version="8.43 "; loaded version="8.44 2020-02-12"
[:warn] [pid 6604:tid 380] ModSecurity: Loaded PCRE do not match with compiled!
[:notice] [pid 6604:tid 380] ModSecurity: LUA compiled version="Lua 5.2"
[:notice] [pid 6604:tid 380] ModSecurity: YAJL compiled version="2.1.0"
[:notice] [pid 6604:tid 380] ModSecurity: LIBXML compiled version="2.9.9"
[:notice] [pid 6604:tid 380] ModSecurity: StatusEngine call: "2.9.3,Apache/2.4.43 (Win64) Ope,1.7.0/1.7.0,8.43/8.44 2020-02-12,Lua 5.2,2.9.9,65f95f630f5ad88de1f990817976146c35130ef4"
[:notice] [pid 6604:tid 380] ModSecurity: StatusEngine call successfully sent. For more information visit: http://status.modsecurity.org/
[md:error] [pid 6604:tid 380] (OS 80)The file exists.  : AH10069: domain.dom: error loading staged set
[mpm_winnt:notice] [pid 6604:tid 380] AH00354: Child: Starting 150 worker threads.

The problem is caused by mod_md, and related error_log record is:

Code:
AH10069: domain.dom: error loading staged set

I Googled for it, and found only mod_md source code:
Code:
+static void load_stage_sets(apr_array_header_t *names, apr_pool_t *p,
+                            md_reg_t *reg, server_rec *s)
+{
+    const char *name;
+    apr_status_t rv;
+    int i;
+   
+    for (i = 0; i < names->nelts; ++i) {
+        name = APR_ARRAY_IDX(names, i, const char*);
+        if (APR_SUCCESS == (rv = md_reg_load(reg, name, p))) {
+            ap_log_error( APLOG_MARK, APLOG_INFO, rv, s, APLOGNO(10068)
+                         "%s: staged set activated", name);
+        }
+        else if (!APR_STATUS_IS_ENOENT(rv)) {
+            ap_log_error( APLOG_MARK, APLOG_ERR, rv, s, APLOGNO(10069)
+                         "%s: error loading staged set", name);
+        }
+    }
+    return;

Full source code can be found here.

Any ideas what can cause this issue? I am not programmer and can't understand all the logic. But I want to solve this issue.

Please advise!


Last edited by EIKA on Wed 05 Aug '20 22:43; edited 4 times in total
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 35
Location: Russia

PostPosted: Wed 05 Aug '20 22:26    Post subject: Reply with quote

I am not sure that it does matter, but I have HTTP2 disabled (all lines are commended out):

Code:
#LoadModule http2_module modules/mod_http2.so
...
...
# <IfModule http2_module>
#    ProtocolsHonorOrder On
#    Protocols h2 h2c http/1.1
# </IfModule>

And my SSL config is:

Code:
Listen 443

SSLPassPhraseDialog  builtin
SSLSessionCache        "shmcb:${SRVROOT}/logs/ssl_scache(512000)"

SSLSessionCacheTimeout  300

SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH+aRSA+RC4 EECDH EDH+aRSA RC4 !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !RC4"

MDCertificateAuthority https://acme-v02.api.letsencrypt.org/directory
MDCertificateAgreement accepted
MDRenewWindow 31d
MDNotifyCmd "d:/Apache/bin/mod_md.bat"

MDomain domain.dom www.domain.dom
<VirtualHost *:443>
    ServerName domain.dom
    ServerAlias www.domain.dom
...
...
...
</VirtualHost>

MDomain dev.domain.dom www.dev.domain.dom
<VirtualHost *:443>
    ServerName dev.domain.dom
    ServerAlias www.dev.domain.dom
...
...
...
</VirtualHost>
Back to top
nono303



Joined: 20 Dec 2016
Posts: 118
Location: France, Lille

PostPosted: Thu 06 Aug '20 7:31    Post subject: Reply with quote

Hi,

Have you ever opened an issue ticket at https://github.com/icing/mod_md/issues ?
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 35
Location: Russia

PostPosted: Sat 08 Aug '20 8:55    Post subject: Reply with quote

Hi Nono! I will do.
Back to top


Reply to topic   Topic: mod_md error: error loading staged set View previous topic :: View next topic
Post new topic   Forum Index -> Third-party Modules