logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache won't start
Author
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Tue 09 Mar '21 17:42    Post subject: Apache won't start Reply with quote

I'm trying to listen to my server at localhost: 8080
I can't listen at port 80 because Skype is using that port and there is no way to change that port in the Skype settings.
My Windows Event Viewer says
The server {F3B4E234-7A68-4E43-B813-E4BA55A065F6} did not register with DCOM within the required timeout.

My XAMMP Control Panel says:
Error: Apache shutdown unexpectedly. This may be due to a blocked port, missing dependencies, improper privileges, a crash, or a shutdown by another method.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 38
Location: Paris, France, EU

PostPosted: Wed 10 Mar '21 10:29    Post subject: Reply with quote

Hi,

It is imperative to change the Skype configuration to NOT use port 80 or 443.
Do this by starting SKYPE and using the menus do - Tools -> Options -> Advanced Settings -> Connection:
Uncheck "Use ports 80 and 443 as an alternative."

But... the Windows 10 tiled app versions of SKYPE may not allow you to change this, so uninstall the tiled app and install SKYPE (If you need it) from a download, it will work just the same, but it will also allow you to make the above configuration changes.
Back to top
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Wed 10 Mar '21 14:58    Post subject: Reply with quote

I went to skype.com and looked at the downloads page but there was no option to download an earlier version of Skype. The earlier versions allow you to change the port but the latest versions do not. So I can't change the port on my version of Skype.
Back to top
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Wed 10 Mar '21 16:38    Post subject: Reply with quote

I went to Oldversion.com and found an early version of Skype. I am uninstalling my current Skype now and will install the older one afterwards.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 38
Location: Paris, France, EU

PostPosted: Wed 10 Mar '21 16:41    Post subject: Reply with quote

You have several solutions:
- 1 - Uninstall Skype completely and use an application that does not appropriate ports 80 and 443 which are reserved for http and https protocols and not for VOIP.
- 2 - Flog Microsoft with nettles so that the option not to use ports 80 and 443 is finally put back in Skype, it's been promised for more than three years.
- 3 - Change an XAMPP parameter so that Apache uses a port other than 80, for example 8080.
Back to top
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Wed 10 Mar '21 17:37    Post subject: Reply with quote

I uninstalled Skype and re-started my computer but I still get the following error:

Port 80 in use by "Unable to open process" with PID 4!
Apache WILL NOT start without the configured ports free!
You need to uninstall/disable/reconfigure the blocking application or reconfigure Apache and the Control Panel to listen on a different port

I've already tried using port 8080 but that doesn't work either.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 38
Location: Paris, France, EU

PostPosted: Wed 10 Mar '21 19:56    Post subject: Reply with quote

Hi,

There may also be IIS that uses port 80.

(W7/W8/W10) Control Panel, Programs and Features, Turn Windows features on or off
(W7/WCool Uncheck :
-- Main Web Internet service instance (IIS)
-- All items of the branch : Internet services(IIS)
-- All items of the branch : Activation Windows service process
(W10) Uncheck :
-- Main instance Web of Internet Information Services (IIS)
-- All items of the branch : Internet Information Services

Then OK.
It may be necessary to restart the machine.
Back to top
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Thu 11 Mar '21 15:12    Post subject: Reply with quote

Thanks for all your input, Otomatic

I cleared all of the checkboxes for IIS and now I don't get the error message about using the port but I still get the error message as follows:

Error: Apache shutdown unexpectedly. This may be due to a blocked port, missing dependencies, improper privileges, a crash, or a shutdown by another method. Press the Logs button to view error logs and check the Windows Event Viewer for more clues. If you need more help, copy and post this entire log window on the forums.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 38
Location: Paris, France, EU

PostPosted: Fri 12 Mar '21 12:22    Post subject: Reply with quote

Hi,

You have to ask XAMPP. I don't know how XAMPP configures Apache.
And, as suggested, see the errors in the event viewer.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6966
Location: Germany, Next to Hamburg

PostPosted: Fri 12 Mar '21 15:21    Post subject: Reply with quote

Run cmd as Adminstrator

Code:

netstat -ano | findstr /R 0.0:80 && netstat -ano | findstr /R 0.0:443


If that shows nothing, use the same cmd, still as Administrator, cd to apache bin path and run httpd.exe
Back to top
makamo66@gmail.com



Joined: 09 Mar 2021
Posts: 6
Location: NEW YORK

PostPosted: Fri 12 Mar '21 16:59    Post subject: Reply with quote

Thanks, James Blond
I had misspelled my DocumentRoot at C:/xampp/htdocs/ I corrected the spelling and it's working now!
Back to top


Reply to topic   Topic: Apache won't start View previous topic :: View next topic
Post new topic   Forum Index -> Apache