logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache not starting on xampp, PHP warning
Author
chrisMadufor



Joined: 26 May 2021
Posts: 2

PostPosted: Wed 26 May '21 11:17    Post subject: Apache not starting on xampp, PHP warning Reply with quote

Good day,
Please I have a problem I need solved. I installed xampp and now apache does not start. I have pretty much tried every solution on the internet which includes clearing web services and changing the port number on the apache config files. Nothing seems to be working.

This is the error message I get;

Error: Apache shutdown unexpectedly.
8:51:55 AM [Apache] This may be due to a blocked port, missing dependencies,
8:51:55 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:51:55 AM [Apache] Press the Logs button to view error logs and check
8:51:55 AM [Apache] the Windows Event Viewer for more clues
8:51:55 AM [Apache] If you need more help, copy and post this
8:51:55 AM [Apache] entire log window on the forums

And when I checked the event viewer, the error message I got there was;

php[8356]
PHP Warning: 'C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll' 14.0 is not compatible with this PHP build linked with 14.28 (c:\xampp\apache\bin\httpd.exe)

Please I will appreciate any help I can get.
Thanks.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 38
Location: Paris, France, EU

PostPosted: Wed 26 May '21 16:23    Post subject: Re: Apache not starting on xampp, PHP warning Reply with quote

chrisMadufor wrote:
php[8356]
PHP Warning: 'C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll' 14.0 is not compatible with this PHP build linked with 14.28 (c:\xampp\apache\bin\httpd.exe)

You are not up to date with VC++ redistributables
Go to the "Downloads" page and install the latest Visual C++ Redistributable for Visual Studio 2015-2019.
Remember that with a 64 bit version of Windows you need to install both 32 AND 64 bit versions.
Back to top
chrisMadufor



Joined: 26 May 2021
Posts: 2

PostPosted: Thu 27 May '21 5:42    Post subject: Reply with quote

Thank you @Otomatic. I installed the latest Visual C++ Redistributable and everything works perfectly.
Back to top


Reply to topic   Topic: Apache not starting on xampp, PHP warning View previous topic :: View next topic
Post new topic   Forum Index -> Apache