logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> News & Hangout View previous topic :: View next topic
Reply to topic   Topic: Apache httpd 2.4.48 GA Available :: Update
Author
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2880
Location: Hilversum, NL, EU

PostPosted: Wed 26 May '21 9:59    Post subject: Apache httpd 2.4.48 GA Available :: Update Reply with quote

Apache httpd 2.4.48 is released as GA.

26 August 2021 Update, see below

ASF and Apachelounge changes : https://www.apachelounge.com/Changelog-2.4.html

Documentation: http://httpd.apache.org/docs/2.4/

Build with dependencies:

- openssl 1.1.1l
- nghttp2 1.44.0
- jansson 2.13.1
- curl 7.78.0
- apr 1.7.0
- apr-util 1.6.1
- apr-iconv 1.2.2
- zlib 1.2.11
- brotli 1.0.9
- pcre 8.45
- libxml2 2.9.12
- lua 5.2.4
- expat 2.4.1

One Redistributable for VC14, VC15 and VS16
For VC14, VC15 and VS16 there is now only one Redistributable, called Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019

When you have already installed the VC14 and/or VC15 Redistributable. Then after install of the new, the Redistributable VC14/15 is updated from 14.0x.xx/14.1x.xx to the new one 14.2x.xx , it is called Microsoft Visual C++ 2015-2019 Redistributable and you can still use VC15/14.

Note from Microsoft: Visual C++ 2015, 2017 and 2019 all share the same redistributable files.
For example, installing the Visual C++ 2015-2019 Redistributable will affect programs built with Visual C++ 2015 and 2017 also. However, installing the Visual C++ 2015 Redistributable will not replace the newer versions of the files installed by the Visual C++ 2015-2019 Redistributable.

This is different from all previous Visual C++ versions, as they each had their own distinct runtime files, not shared with other versions.

VS16, VC14 and VC15 are backward compatible.
VS16 is backward compatible to VC15/14 and VC15 backward to VC14. That means for example, a VC15/14 module can be used inside a VS16 binary (for example PHP VC15/14 as module).

Why we have a VS16 now
Maybe you noticed that we call Visual Studio C++ 2019 VS16 instead of VC16. In consultation with the PHP team we both now going to use VS16. VS16 is the version number of Visual Studio 2019.

The reason is, that VC15 is already a fictional identity, as the real VC++ version is 14.1, as you know. The new default one is now 14.2 still, not 16. Also, the version numbers move a lot faster now that in versions before VS2015. Thus, it turns out better to refer to the Visual Studio version and it's default toolset, than trying to catch up with the VC++ version which became unpredictable. Back in time, we've started to build with a preview of VS2017, which was indeed VC15, but after the GA release the version has been changed to 14.1, where we didn't catch up.


When you have hangs, slow traffic and/or when having in your log entries like Asynchronous AcceptEx failed. You can try the following settings:

AcceptFilter http none
AcceptFilter https none
EnableSendfile off
EnableMMAP off

Enjoy,

Steffen


Last edited by Steffen on Thu 26 Aug '21 14:10; edited 1 time in total
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2880
Location: Hilversum, NL, EU

PostPosted: Wed 02 Jun '21 10:16    Post subject: Reply with quote

In the changelog added the fixed Security vulnerabilities (CVE's) for 2.4.47 and 2.4.48

Most CVE fixed in this releases are rated from moderate to low impact.
Only one, CVE-2021-31618 is rated as important and could be exploited for some DoS

Also listed at https://httpd.apache.org/security/vulnerabilities_24.html
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1141
Location: Amsterdam, NL, EU

PostPosted: Mon 28 Jun '21 18:22    Post subject: Reply with quote

Quote from the changelog of Dovecot 2.3.15:
Quote:
Removed support for Lua 5.2. Use version 5.1 or 5.3 instead.

https://dovecot.org/pipermail/dovecot-news/2021-June/000457.html
Different platform but it seems strange that Dovecot drops Lua 5.2 and ALís Apache ships with exactly that version.

Edit The commit that removed the support for Lua5.2 is here: https://github.com/dovecot/core/commit/508a7f756609541e4eca6d30616db2f28ce2f7aa
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1141
Location: Amsterdam, NL, EU

PostPosted: Wed 30 Jun '21 0:14    Post subject: Reply with quote

LibXML2 fixed a security issue (CVE-2021-3541). See https://gitlab.gnome.org/GNOME/libxml2/-/commit/8598060bacada41a0eb09d95c97744ff4e428f8e
It is recommended to update to LibXML2 2.9.12.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2880
Location: Hilversum, NL, EU

PostPosted: Thu 26 Aug '21 14:09    Post subject: Reply with quote

Update dependencies OpenSSL, PCRE, libxml2, nghttp2, Curl and Expat.

See Changelog https://www.apachelounge.com/Changelog-2.4.html
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2880
Location: Hilversum, NL, EU

PostPosted: Fri 27 Aug '21 10:23    Post subject: Reply with quote

VC15 now also available
Back to top


Reply to topic   Topic: Apache httpd 2.4.48 GA Available :: Update View previous topic :: View next topic
Post new topic   Forum Index -> News & Hangout