logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Okay Just A Quickie
Author
Timlab55



Joined: 07 Nov 2021
Posts: 17
Location: Aiken

PostPosted: Mon 06 Dec '21 19:12    Post subject: Okay Just A Quickie Reply with quote

I have everything install (Apache, PHP, MySql and phpadmin) and everything seems to be working right. Then when I go to install the certification for let's Encrypt, they are saying that I'm missing a plug in from Apache. I have no clue what plug in they are requiring, or maybe I missed a step when putting in Apache. Either way, my question (let's be honest), is can I just uninstall Apache, re-install it and be good to go, or do I need to start from the beginning again?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7061
Location: Germany, Next to Hamburg

PostPosted: Tue 07 Dec '21 11:11    Post subject: Reply with quote

Any error message?
How do you try to install the certificate?
Back to top
Timlab55



Joined: 07 Nov 2021
Posts: 17
Location: Aiken

PostPosted: Tue 07 Dec '21 18:50    Post subject: Reply with quote

Not trying to be a smart a$$, but in my message I posted there was a plug in missing from apache. My only question is: If I uninstall apache, then reinstall apache, will PHP, MySql and phpmyadmin be applied to the new install or would I have to go back and start over again installing everything?
Thanks
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7061
Location: Germany, Next to Hamburg

PostPosted: Wed 08 Dec '21 10:11    Post subject: Reply with quote

mod_md can pull and install certs from Letís Encrypt. Or you need a client for the command line. Choose your poison https://letsencrypt.org/docs/client-options/
Back to top
Timlab55



Joined: 07 Nov 2021
Posts: 17
Location: Aiken

PostPosted: Wed 08 Dec '21 16:19    Post subject: Reply with quote

I choose my poison sir and I won. My website is locked and almost loaded.
However, I'm just still wondering about it. I've never worked in Linux before. So the question still remains. If I load apache in and then php, mysql and then phpmyadmin and then I realize that I screwed up with apache, can I just replace apache or do I need to reinstall php, mysql and phpmyadmin?
Thanks
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7061
Location: Germany, Next to Hamburg

PostPosted: Wed 08 Dec '21 17:36    Post subject: Reply with quote

I'm most familiar with Debian Linux. There every software has its own configuration in /etc/

If you want really remove it, use apt-get purge <package>

apt-get remove only deletes the binaries, and keeps the configuration files.

So yes, you can do that, just reinstall apache.
Back to top


Reply to topic   Topic: Okay Just A Quickie View previous topic :: View next topic
Post new topic   Forum Index -> Apache