logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS Twitter


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> News & Hangout View previous topic :: View next topic
Reply to topic   Topic: Apache 2.4.54 build Visual Studio 2022 (VS17) available
Author
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2970
Location: Hilversum, NL, EU

PostPosted: Tue 08 Nov '22 13:42    Post subject: Apache 2.4.54 build Visual Studio 2022 (VS17) available Reply with quote

Changes : https://www.apachelounge.com/Changelog-2.4.html

Build with OpenSSL 3.0.7
LUA upgraded to 5.4.4 (VS16 was 5.2.4)

Notes on OpenSSL 3.0.7:

- Is not compatible with PHP running as module. The next version PHP 8.2 has 3.0.x supprt.
Running with mod_fcgid no issues seen.

- With too weak certificates/ciphers Apache does not start.

When you have VS16/15/14 modules you can use them. VS17 and VS16/15/14 are compatible.

!! Do not forget to install the Visual C++ Redistributable for Visual Studio 2015-2022 x64 from the download page.

Build with dependencies:

- openssl 3.0.7
- nghttp2 1.50.0
- jansson 2.14
- curl 7.86.0
- apr 1.7.0
- apr-util 1.6.1
- apr-iconv 1.2.2
- zlib 1.2.13
- brotli 1.0.9
- pcre2 10.40
- libxml2 2.10.3
- lua 5.4.4
- expat 2.5.0

Enjoy, Steffen
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 93
Location: Paris, France, EU

PostPosted: Thu 10 Nov '22 16:09    Post subject: Reply with quote

Hi,

Quote:
Notes on OpenSSL 3.0.7:
- Is not compatible with PHP running as module. The next version PHP 8.2 has 3.0.x supprt.

By putting in the bin folder of the used Apache VS17 version symbolic links on the :
libcrypto-1_1-x64.dll
libssl-1_1-x64.dll
of the used PHP version, it doesn't seem to be a problem to use PHP as Apache module

For example with PHP 7.4.33 in Apache module :
Code:

[Thu Nov 10 14:56:22.000916 2022] [mpm_winnt:notice] [pid 1632:tid 396] AH00455: Apache/2.4.54 (Win64) OpenSSL/3.0.7 PHP/7.4.33 mod_fcgid/2.3.10-dev configured -- resuming normal operations
[Thu Nov 10 14:56:22.000916 2022] [mpm_winnt:notice] [pid 1632:tid 396] AH00456: Apache Lounge VS17 Server built: Nov  7 2022 15:16:42
[Thu Nov 10 14:56:22.000916 2022] [core:notice] [pid 1632:tid 396] AH00094: Command line: 'E:\\wamp64\\bin\\apache\\apache2.4.54.3\\bin\\httpd.exe -d E:/wamp64/bin/apache/apache2.4.54.3'
[Thu Nov 10 14:56:22.007423 2022] [mpm_winnt:notice] [pid 1632:tid 396] AH00418: Parent: Created child process 19624
[Thu Nov 10 14:56:22.731288 2022] [mpm_winnt:notice] [pid 19624:tid 400] AH00354: Child: Starting 64 worker threads.

I also tried with PHP 8.1.12 and Apache VirtualHost Module in https and it seems to work fine.
Back to top


Reply to topic   Topic: Apache 2.4.54 build Visual Studio 2022 (VS17) available View previous topic :: View next topic
Post new topic   Forum Index -> News & Hangout