logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Other Software View previous topic :: View next topic
Reply to topic   Topic: php non-thread safe issues
Author
mrdj1024



Joined: 03 Apr 2023
Posts: 29
Location: Bridgeton,NJ,USA

PostPosted: Thu 02 Nov '23 13:57    Post subject: php non-thread safe issues Reply with quote

hello!
running wampserver on windows using mpm_winnt module
i read when using fastcgid php does not need a thread safe version so i replaced it with non thread safe version and my php apps do appear to work put in php error log i get these warnings that i did not get before :

https://apaste.info/uXGt
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 156
Location: Paris, France, EU

PostPosted: Thu 02 Nov '23 15:28    Post subject: Reply with quote

Hi,

I supply Wampserver, a fully functional server whether with PHP as an Apache module or in FCGI mode, and whatever Apache and PHP versions are used (within certain limits).

You have fun replacing a PHP TS version with an NTS version and then complain that there are errors!

Just because FCGI mode doesn't require a PHP TS version doesn't mean it will only work with an NTS version!

When it's working properly, there's no need to try and fix it.
Back to top


Reply to topic   Topic: php non-thread safe issues View previous topic :: View next topic
Post new topic   Forum Index -> Other Software